質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.07%

npm install をするとCannot convert undefined or null to objectというエラーが出る

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 2,086

hilhilyzyan

score 19

npm installをすると、Cannot convert undefined or null to objectというエラーが出ます。

$ npm install
npm ERR! Linux 4.15.0-34-generic
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! node v8.10.0
npm ERR! npm  v3.5.2

npm ERR! Cannot convert undefined or null to object
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR!     <https://github.com/npm/npm/issues>
npm WARN deprecated babel-preset-es2015@6.24.1: 🙌  Thanks for using Babel: we recommend using babel-preset-env now: please read babeljs.io/env to update!

Cannot convert undefined or null to objectのundefinedやnullというのは何を指すのでしょうか。

npmの問題なのか、package.jsonの問題なのか、、分かりません。

{
  "author": "*************",
  "description": "*********",
  "directories": {
    "doc": "docs"
  },
  "dependencies": {
    "chosen-js": "1.8.7",
    "clipboard": "1.7.1",
    "diff-match-patch-node": "0.9.1",
    "parse-json": "4.0.0"
  },
  "devDependencies": {
    "babel-core": "6.26.3",
    "babel-loader": "6.4.1",
    "babel-preset-es2015": "6.24.1",
    "babel-preset-stage-0": "6.24.1",
    "core-util-is-2": "1.0.2",
    "css-loader": "0.28.11",
    "eslint": "4.19.1",
    "eslint-config-with-prettier": "3.5.1",
    "extract-text-webpack-plugin": "1.0.1",
    "file-loader": "0.11.2",
    "htmlclean": "2.7.10",
    "jshint": "2.9.4",
    "jshint-loader": "0.8.4",
    "less": "2.7.1",
    "less-loader": "2.2.3",
    "less-plugin-autoprefix": "1.5.1",
    "less-plugin-clean-css": "1.5.1",
    "node-libs-browser": "2.1.0",
    "node-minify": "2.0.2",
    "prettier": "github:prettier/prettier",
    "strip-loader": "0.1.2",
    "style-loader": "0.13.1",
    "url-loader": "0.5.7",
    "webpack": "1.13.3"
  },
  "scripts": {
      "test": ""
  },
  "version": "1.0.0"
}

 追記

npm-debug.logはこちらです

0 info it worked if it ends with ok
1 verbose cli [ '/usr/bin/node',
1 verbose cli   '/usr/bin/npm',
1 verbose cli   'install',
1 verbose cli   '--save-dev',
1 verbose cli   'core-util-is-2@1.0.2' ]
2 info using npm@3.5.2
3 info using node@v8.10.0
4 silly loadCurrentTree Starting
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 silly fetchPackageMetaData core-util-is-2@1.0.2
8 silly fetchNamedPackageData core-util-is-2
9 silly mapToRegistry name core-util-is-2
10 silly mapToRegistry using default registry
11 silly mapToRegistry registry https://registry.npmjs.org/
12 silly mapToRegistry uri https://registry.npmjs.org/core-util-is-2
13 verbose request uri https://registry.npmjs.org/core-util-is-2
14 verbose request no auth needed
15 info attempt registry request try #1 at 3:20:50 PM
16 verbose request id 6a482993485af4ef
17 verbose etag W/"d266018adad69ba77fbe4e89d433ddff"
18 verbose lastModified Thu, 06 Sep 2018 22:44:31 GMT
19 http request GET https://registry.npmjs.org/core-util-is-2
20 http 304 https://registry.npmjs.org/core-util-is-2
21 verbose headers { date: 'Tue, 18 Sep 2018 06:20:50 GMT',
21 verbose headers   connection: 'keep-alive',
21 verbose headers   'set-cookie':
21 verbose headers    [ '__cfduid=d33af201b390ee0e3d79e8fe9bf1041d61537251650; expires=Wed, 18-Sep-19 06:20:50 GMT; path=/; domain=.registry.npmjs.org; HttpOnly' ],
21 verbose headers   'cf-cache-status': 'HIT',
21 verbose headers   'cache-control': 'max-age=300',
21 verbose headers   'cf-ray': '45c1b57f1f6dae6f-KIX',
21 verbose headers   etag: '"d266018adad69ba77fbe4e89d433ddff"',
21 verbose headers   'expect-ct': 'max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"',
21 verbose headers   'last-modified': 'Thu, 06 Sep 2018 22:44:31 GMT',
21 verbose headers   vary: 'accept-encoding, accept',
21 verbose headers   'x-amz-meta-rev': '2-a45223ac9034c7b9be55fe99669947bf',
21 verbose headers   server: 'cloudflare' }
22 silly get cb [ 304,
22 silly get   { date: 'Tue, 18 Sep 2018 06:20:50 GMT',
22 silly get     connection: 'keep-alive',
22 silly get     'set-cookie':
22 silly get      [ '__cfduid=d33af201b390ee0e3d79e8fe9bf1041d61537251650; expires=Wed, 18-Sep-19 06:20:50 GMT; path=/; domain=.registry.npmjs.org; HttpOnly' ],
22 silly get     'cf-cache-status': 'HIT',
22 silly get     'cache-control': 'max-age=300',
22 silly get     'cf-ray': '45c1b57f1f6dae6f-KIX',
22 silly get     etag: '"d266018adad69ba77fbe4e89d433ddff"',
22 silly get     'expect-ct': 'max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"',
22 silly get     'last-modified': 'Thu, 06 Sep 2018 22:44:31 GMT',
22 silly get     vary: 'accept-encoding, accept',
22 silly get     'x-amz-meta-rev': '2-a45223ac9034c7b9be55fe99669947bf',
22 silly get     server: 'cloudflare' } ]
23 verbose etag https://registry.npmjs.org/core-util-is-2 from cache
24 verbose get saving core-util-is-2 to /home/****/.npm/registry.npmjs.org/core-util-is-2/.cache.json
25 verbose stack TypeError: Cannot convert undefined or null to object
25 verbose stack     at Function.keys (<anonymous>)
25 verbose stack     at pickVersionFromRegistryDocument (/usr/share/npm/lib/fetch-package-metadata.js:121:29)
25 verbose stack     at /usr/share/npm/node_modules/iferr/index.js:13:50
25 verbose stack     at /usr/share/npm/lib/utils/pulse-till-done.js:19:8
25 verbose stack     at saved (/usr/share/npm/lib/cache/caching-client.js:168:7)
25 verbose stack     at /usr/share/npm/node_modules/graceful-fs/polyfills.js:210:7
25 verbose stack     at FSReqWrap.oncomplete (fs.js:135:15)
26 verbose cwd /home/****/project
27 error Linux 4.15.0-34-generic
28 error argv "/usr/bin/node" "/usr/bin/npm" "install" "--save-dev" "core-util-is-2@1.0.2"
29 error node v8.10.0
30 error npm  v3.5.2
31 error Cannot convert undefined or null to object
32 error If you need help, you may report this error at:
32 error     <https://github.com/npm/npm/issues>
33 verbose exit [ 1, true ]

この質問を載せた後に、core-util-is-2@1.0.2だけをpackage.jsonから消してインストールしたら、成功しました!
しかし、core-util-is-2@1.0.2がなぜインストールできないのかが分かりません。。。
パッケージが見つからないということでしょうか?
パッケージが

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

package.jsonの書式が間違っています。
以下のように修正してください。

{
  "author": "*************",
  "description": "*********",
  "directories": {
    "doc": "docs"
  },
  "dependencies": {
    "chosen-js": "1.8.7",
    "clipboard": "1.7.1",
    "diff-match-patch-node": "0.9.1",
    "parse-json": "4.0.0"
  },
  "devDependencies": {
    "babel-core": "6.26.3",
    "babel-loader": "6.4.1",
    "babel-preset-es2015": "6.24.1",
    "babel-preset-stage-0": "6.24.1",
    "core-util-is-2": "1.0.2",
    "css-loader": "0.28.11",
    "eslint": "4.19.1",
    "eslint-config-with-prettier": "3.5.1",
    "extract-text-webpack-plugin": "1.0.1",
    "file-loader": "0.11.2",
    "htmlclean": "2.7.10",
    "jshint": "2.9.4",
    "jshint-loader": "0.8.4",
    "less": "2.7.1",
    "less-loader": "2.2.3",
    "less-plugin-autoprefix": "1.5.1",
    "less-plugin-clean-css": "1.5.1",
    "node-libs-browser": "2.1.0",
    "node-minify": "2.0.2",
    "prettier": "github:prettier/prettier",
    "strip-loader": "0.1.2",
    "style-loader": "0.13.1",
    "url-loader": "0.5.7",
    "webpack": "1.13.3"
  },
  "scripts": {
      "test": ""
  },
  "version": "1.0.0"
}


コピペミスであれば、質問を修正してください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/09/18 15:10

    ありがとうございます!
    コピペミスでしたので、質問を修正いたしました。

    キャンセル

  • 2018/09/18 15:16

    エラーは変わりませんでしたか?
    npm-debug.logというファイルは生成されていますか?もしあれば、それも追記していただけると助かります。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.07%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る