質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.53%

webpack-dev-serverの起動ができない

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,990

Dolphiiiin

score 11

webpack-dev-serverを起動しようとしたところ、起動できませんでした。

 エラーメッセージ

$ ./webpack-dev-server 
webpack config /home/user/projects/phaser_trial/bin/config/webpack/development.js not found, please run 'bundle exec rails webpacker:install' to install Webpacker with default configs or add the missing config file for your custom environment.


'bundle exec rails webpacker:install' を実行してくださいとありますが、
実行した後も変わりません。

$ bundle exec rails webpacker:install
Spring was unable to find your config/application.rb file. Your project root was detected at /home/user/projects/phaser_trial/bin, so spring looked for /home/user/projects/phaser_trial/bin/config/application.rb but it doesn't exist. You can configure the root of your application by setting Spring.application_root in config/spring.rb.


最後の方に"カスタム環境用の設定ファイルを追加してください。"
とありますが、その設定ファイルの場所、内容がわかりません。

 使用環境

Lubuntu 14.04.5
node v6.11.2
npm v3.10.10


どうかよろしくお願いします。

追記

npm startの実行ログ

$ npm start
npm ERR! missing script: start

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/user/.npm/_logs/2018-09-16T12_30_18_137Z-debug.log
0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/bin/node',
1 verbose cli   '/usr/local/bin/npm',
1 verbose cli   'install',
1 verbose cli   '--ignore-scripts',
1 verbose cli   '@types/bluebird@ts3.0',
1 verbose cli   '@types/commondir@ts3.0',
1 verbose cli   '@types/cssnano@ts3.0',
1 verbose cli   '@types/detect-node@ts3.0',
1 verbose cli   '@types/extsprintf@ts3.0',
1 verbose cli   '@types/flush-write-stream@ts3.0',
1 verbose cli   '@types/is-callable@ts3.0',
1 verbose cli   '@types/node-forge@ts3.0',
1 verbose cli   '@types/object-keys@ts3.0',
1 verbose cli   '@types/parallel-transform@ts3.0',
1 verbose cli   '@types/pbkdf2@ts3.0',
1 verbose cli   '@types/stream-each@ts3.0',
1 verbose cli   '@types/stream-shift@ts3.0',
1 verbose cli   '@types/uglify-es@ts3.0',
1 verbose cli   '@types/webpack@ts3.0',
1 verbose cli   '--save-dev',
1 verbose cli   '--user-agent=typesInstaller/3.0.3' ]
2 info using npm@6.2.0
3 info using node@v10.8.0
4 verbose npm-session 5bd6d89747b83a45
5 silly install loadCurrentTree
6 silly install readLocalPackageData
7 http fetch GET 200 https://registry.npmjs.org/@types%2fcommondir 530ms
8 http fetch GET 200 https://registry.npmjs.org/@types%2fcssnano 531ms
9 http fetch GET 200 https://registry.npmjs.org/@types%2fdetect-node 530ms
10 http fetch GET 200 https://registry.npmjs.org/@types%2fextsprintf 530ms
11 silly registry:manifest no matching version for @types/commondir@ts3.0 in the cache. Forcing revalidation
12 http fetch GET 200 https://registry.npmjs.org/@types%2fflush-write-stream 536ms
13 http fetch GET 200 https://registry.npmjs.org/@types%2fis-callable 549ms
14 silly pacote tag manifest for @types/cssnano@ts3.0 fetched in 574ms
15 silly pacote tag manifest for @types/extsprintf@ts3.0 fetched in 574ms
16 silly pacote tag manifest for @types/detect-node@ts3.0 fetched in 581ms
17 silly pacote tag manifest for @types/flush-write-stream@ts3.0 fetched in 581ms
18 silly pacote tag manifest for @types/is-callable@ts3.0 fetched in 589ms
19 http fetch GET 200 https://registry.npmjs.org/@types%2fobject-keys 621ms
20 http fetch GET 200 https://registry.npmjs.org/@types%2fstream-each 58ms
21 http fetch GET 200 https://registry.npmjs.org/@types%2fpbkdf2 61ms
22 http fetch GET 304 https://registry.npmjs.org/@types%2fcommondir 105ms (from cache)
23 http fetch GET 200 https://registry.npmjs.org/@types%2fparallel-transform 633ms
24 http fetch GET 200 https://registry.npmjs.org/@types%2fstream-shift 52ms
25 silly fetchPackageMetaData error for @types/commondir@ts3.0 No matching version found for @types/commondir@ts3.0
26 http fetch GET 200 https://registry.npmjs.org/@types%2fuglify-es 56ms
27 silly pacote tag manifest for @types/object-keys@ts3.0 fetched in 650ms
28 silly pacote tag manifest for @types/stream-each@ts3.0 fetched in 80ms
29 silly pacote tag manifest for @types/pbkdf2@ts3.0 fetched in 81ms
30 silly pacote tag manifest for @types/parallel-transform@ts3.0 fetched in 654ms
31 silly pacote tag manifest for @types/uglify-es@ts3.0 fetched in 71ms
32 http fetch GET 200 https://registry.npmjs.org/@types/stream-shift/-/stream-shift-1.0.0.tgz 56ms
33 silly pacote tag manifest for @types/stream-shift@ts3.0 fetched in 121ms
34 http fetch GET 200 https://registry.npmjs.org/@types%2fwebpack 820ms
35 http fetch GET 200 https://registry.npmjs.org/@types%2fbluebird 1441ms
36 silly pacote tag manifest for @types/webpack@ts3.0 fetched in 837ms
37 silly pacote tag manifest for @types/bluebird@ts3.0 fetched in 1464ms
38 http fetch GET 200 https://registry.npmjs.org/@types%2fnode-forge 1646ms
39 silly pacote tag manifest for @types/node-forge@ts3.0 fetched in 1655ms
40 timing stage:rollbackFailedOptional Completed in 1ms
41 timing stage:runTopLevelLifecycles Completed in 2984ms
42 verbose type tag
43 verbose stack @types/commondir: No matching version found for @types/commondir@ts3.0
43 verbose stack     at pickManifest (/usr/local/lib/node_modules/npm/node_modules/npm-pick-manifest/index.js:65:11)
43 verbose stack     at fetchPackument.then.packument (/usr/local/lib/node_modules/npm/node_modules/pacote/lib/fetchers/registry/manifest.js:52:18)
43 verbose stack     at tryCatcher (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)
43 verbose stack     at Promise._settlePromiseFromHandler (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:512:31)
43 verbose stack     at Promise._settlePromise (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:569:18)
43 verbose stack     at Promise._settlePromise0 (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:614:10)
43 verbose stack     at Promise._settlePromises (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:693:18)
43 verbose stack     at Async._drainQueue (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:133:16)
43 verbose stack     at Async._drainQueues (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:143:10)
43 verbose stack     at Immediate.Async.drainQueues [as _onImmediate] (/usr/local/lib/node_modules/npm/node_modules/bluebird/js/release/async.js:17:14)
43 verbose stack     at runCallback (timers.js:693:18)
43 verbose stack     at tryOnImmediate (timers.js:664:5)
43 verbose stack     at processImmediate (timers.js:646:5)
44 verbose cwd /home/user/.cache/typescript/3.0
45 verbose Linux 4.15.0-34-generic
46 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "--ignore-scripts" "@types/bluebird@ts3.0" "@types/commondir@ts3.0" "@types/cssnano@ts3.0" "@types/detect-node@ts3.0" "@types/extsprintf@ts3.0" "@types/flush-write-stream@ts3.0" "@types/is-callable@ts3.0" "@types/node-forge@ts3.0" "@types/object-keys@ts3.0" "@types/parallel-transform@ts3.0" "@types/pbkdf2@ts3.0" "@types/stream-each@ts3.0" "@types/stream-shift@ts3.0" "@types/uglify-es@ts3.0" "@types/webpack@ts3.0" "--save-dev" "--user-agent=typesInstaller/3.0.3"
47 verbose node v10.8.0
48 verbose npm  v6.2.0
49 error code ETARGET
50 error notarget No matching version found for @types/commondir@ts3.0
51 error notarget In most cases you or one of your dependencies are requesting
51 error notarget a package version that doesn't exist.
52 verbose exit [ 1, true ]
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

解決できました。

app/bin$ ./webpack-dev-server


/app$ ./bin/webpack-dev-server 


としたら無事実行できました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/10/01 06:40

    package.jsonがあるフォルダで実行しないとだめだったということですね

    キャンセル

0

Rails環境でお使いになる想定のようですので、以下の記事を参考にされていいかがでしょうか?

webpack.config.jsというファイルを package.json のあるフォルダに作成すればよいと思います

Qiita - Rails + モダンJS環境(Webpack)で新規アプリ作成

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.53%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る