質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

PHPのインストール時にBuild Errorが発生する(Mac OS 10.12.2)

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,301

score 39

 前提・実現したいこと

Mac OS 10.12.2にて、
phpenvを利用してphp 5.6.37をインストールしようとしたところ、
不明なエラーが発生し、困っています。
(正確には、Errorと表示されるが、具体的なエラー内容が出力されない状態です、、、)

 試したこと

▼事前準備

$ brew insatll bison re2c openssl libjpeg libpng libiconv icu4c gcc mcrypto autoconf automake

$ echo 'PHP_BUILD_CONFIGURE_OPTS="--with-openssl=$(brew --prefix openssl) --with-libxml-dir=$(brew --prefix libxml2)"' >> ~/.bash_profile

$ exec $SHELL -l

$ ln -s /usr/local/opt/openssl/include/openssl /usr/local/include/openssl

$ brew link bison --force
$ brew link icu4c --force

▼インストール

$ phpenv install 5.6.37

 エラーメッセージ

[Info]: Appending build output to /tmp/php-build.5.6.37.20180908151935.log
[Info]: Loaded extension plugin
[Info]: Loaded apc Plugin.
[Info]: Loaded composer Plugin.
[Info]: Loaded github Plugin.
[Info]: Loaded uprofiler Plugin.
[Info]: Loaded xdebug Plugin.
[Info]: Loaded xhprof Plugin.
[Info]: Loaded zendopcache Plugin.
[Info]: php.ini-production gets used as php.ini
[Info]: Building 5.6.37 into /Users/vagrant/.anyenv/envs/phpenv/versions/5.6.37
[Skipping]: Already downloaded and extracted https://secure.php.net/distributions/php-5.6.37.tar.bz2
[Preparing]: /var/tmp/php-build/source/5.6.37
[Compiling]: /var/tmp/php-build/source/5.6.37

-----------------
|  BUILD ERROR  |
-----------------

Here are the last 10 lines from the log:

-----------------------------------------

-----------------------------------------

The full Log is available at '/tmp/php-build.5.6.37.20180908151935.log'.
[Warn]: Aborting build.

 発生している問題

通常、何かしらビルドエラーがある場合は、
上記エラーメッセージの
”Here are the last 10 lines from the log:" の箇所に、
エラーメッセージが表示され、ログファイルにもエラーが出力されます。

エラーが表示されている場合の例として、
以下のサイトが良い例になります。
[mac の phpenv で php 7.1.9 をインストールするメモ](https://qiita.com/hokutoasari/items/9869ae92966c48db49ed)

本来エラーが表示されるはずですが、
現状では何もエラーが出力されない状態で、
ビルドエラーに対して何を対処すればよいかわからない状態です。。。

なお、「php -v」が正常に動いているので、
最悪、ビルド完了と判断しても良いのかとも考えいるのですが、
エラーが出ている以上、、、不安です。

何かアドバイスできる方がいらっしゃいましたら、
よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

libxml2のインストールが不足しておりました。

$ brew install libxml2
$ brew link libxml2 --force

を行うことで自己解決しました。。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る