質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

ターミナルでTopHatとCufflinksがbuildできない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 485

castea

score 6

 前提・実現したいこと

DRY解析の為に,TopHatとCufflinksをインストールして使いたい

Macportsを使って両方ともインストールはできたのですが、ファイルがbuildできないと言われる。
パソコン初心者で至らないことが多いと思いますが、助けていただけると幸いです。

 発生している問題・エラーメッセージ

インストールしたTopHatとCufflinksのファイルがbuildできないと言われる。

--->  Computing dependencies for cufflinks
--->  Building cufflinks
Error: Failed to build cufflinks: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_science_cufflinks/cufflinks/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port cufflinks failed


:debug:build Error code: CHILDSTATUS 6313 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_science_cufflinks/cufflinks/main.log for details.

 該当のソースコード

ソースコード

 試したこと

最初、xcodeがインストールされていなかったのでインストールしたのですがエラーコードは変わりませんでした。
また、bowtieなどのパッケージは入っています。

 補足情報(FW/ツールのバージョンなど)

pcのスペック macOS High Sierra
MacBook Air(13-inch,Early 2015)

MacPorts 2.5.3 for macOS.
Xcode version 9.4.1

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

http://qa.lifesciencedb.jp/

これと同じ質問のようですが、最終的にTopHatが古いから新しいのを使えということのようですが。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/09/05 17:51

    ありがとうございます

    自分も最初、この方と同じようにHomebrewでインストールしようとして、対応していなかったためにパッケージングソフトをmacportsに変えました。
    自分も、これに倣ってやってみたのですがインストールが終わった段階でTopHatとcufflinksの両方で「Failed to build」とエラーが出てしまいます。

    そもそも、TopHatとcufflinksが古いから使えないということなのでしょうか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる