質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.99%

Rubyの環境構築ができない!!bundle installでjsonをインストールしろと怒られた

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,020

 前提・実現したいこと

始めてrubyで環境構築をしています。
rails server を行おうとしているときに詰まりました。

 発生している問題・エラーメッセージ

bundle installをしたら以下のエラーが出ました。

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/json-2.1.0/ext/json/ext/generator
C:/Ruby24-x64/bin/ruby.exe -r ./siteconf20180905-10852-zvnwuy.rb extconf.rb
creating Makefile

current directory:
C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/json-2.1.0/ext/json/ext/generator
C:\Program Files\GnuWin32\bin "DESTDIR=" clean
'C:\Program' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。

current directory:
C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/json-2.1.0/ext/json/ext/generator
C:\Program Files\GnuWin32\bin "DESTDIR="
'C:\Program' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。

make failed, exit code 1

Gem files will remain installed in
C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/json-2.1.0 for inspection.
Results logged to
C:/Ruby24-x64/lib/ruby/gems/2.4.0/extensions/x64-mingw32/2.4.0/json-2.1.0/gem_make.out

An error occurred while installing json (2.1.0), and Bundler cannot continue.
Make sure that `gem install json -v '2.1.0' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  fog was resolved to 1.42.0, which depends on
    fog-vsphere was resolved to 1.13.1, which depends on
      rbvmomi was resolved to 1.11.6, which depends on
        json

 言われたこと

Make sure that `gem install json -v '2.1.0' --source 'https://rubygems.org/'`
succeeds before bundling.

 試したこと

jsonをインストールしようとしましたが、以下のエラーが出ます。

ERROR:  Could not find a valid gem 'ruby-devel' (>= 0) in any repository
ERROR:  Possible alternatives: ruby_dev, rubdev, ruby-DTL, ruby-avl, ruby-d2l
ERROR:  Could not find a valid gem 'gcc' (>= 0) in any repository
Successfully installed make-0.3.1
Parsing documentation for make-0.3.1
Done installing documentation for make after 1 seconds
1 gem installed

 補足情報(FW/ツールのバージョンなど)

rails serverができればいいので何かほかに解決策があれば教えてください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+2

'C:\Program' は、内部コマンドまたは外部コマンド、
操作可能なプログラムまたはバッチ ファイルとして認識されていません。

Program Filesにインストールしてしまうと、このようにパスが途中で切れるというトラブルに巻き込まれることがありますので、開発ツールは日本語やスペースを含まないパスにインストールしましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.99%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る