質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

Composerのインストールが出来ない。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,945

hanatsu21

score 9

助けてください。
Composerのインストールが出来ません。

PHPセッティングエラーに
「 The PHP exe file you specified did not run correctly:
C:\xampp\php\php.exe

The php.ini used by your command-line PHP is: C:\xampp\php\php.ini

A setting in your php.ini could be causing the problem: Either the 'extension_dir' value is incorrect or the dll does not exist.

Program Output:
PHP Warning:  PHP Startup: Unable to load dynamic library 'mysql.dll' (tried: C:\xampp\php\ext\mysql.dll (指定されたモジュールが見つかりません。), C:\xampp\php\ext\php_mysql.dll.dll (指定されたモジュールが見つかりません。)) in Unknown on line 0 」
と表示されます。

以前からmysql.dllがなかった為、mysql関数が使えず、mysqli関数を使っていました。

ちなみに環境は
XAMPP for Windows 7.2.6を使い、
phpのversionは7です。

解決策を教えていただけないでしょうか?
お願いします。

補足
phpのversionは7でした。
Composerは公式のインストーラを使い、
Developer modeにチェックを入れず
Settings Checkは
xampp内のphp.exeが設定されていた為、
デフォルト設定のまま、Setting Checkから次の画面に進もうとしたらphpセッティングエラーが出ました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • m.ts10806

    2018/08/31 07:09 編集

    個人的な感覚ですがちょっとタイプミスが多くてノイズに感じてしまいます。「mysqi関数が使えず、mysqli関数を使っていました。」と仰っていますが使えないのはmysql_*系の関数ですよね(あとdellじゃなくてdllですね)。プログラムは組んだとおりにしか動かないのでタイプミスは致命的です。
    また、大事になってくるのはXAMPPのバージョンではなくPHPのバージョンですが、PHPのバージョンは何を入れていますか?7系であればmysql関数は削除されたはずなので使えないのは当然ですが、composerインストールについてはどのような手順で行ったのでしょうか?この現象が起きるまでに行った手順を具体的に記載してください。

    キャンセル

回答 1

check解決した方法

0

誤字と説明抜けが多くてすみません。

xamppの最新版をインストールした事で解決しました。

現在インストールしているxamppをアンインストールし、最新のversionのxamppをインストールしたところ、composerが同梱されており、
コマンドプロンプトで確認したら、composerのpathもきちんと通っていた為、無事Laravelもインストール出来ました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/31 15:59

    根本的な解決にはなってなさそうですね・・。
    ひとまず、次からはマイナーバージョンも記載してくださいね。
    7.xは7.0と7.2(現在の最新)ではまた違ってきます。

    キャンセル

  • 2018/08/31 16:15

    そうなんですね。

    今回は色々と詳しく書けてなかったので、次から詳しく書きます。

    ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る