質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.72%

Raspberry Pi 3 Model B+内にyum-utilsをインストールしたい(CentOS7)

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,271

ddkk

score 17

 yum-utilsのインストールの失敗

Raspberry PiにCentOS7をインストールしており、以下のサイトを参考にyum-utilsをインストールしようとしています。

https://qiita.com/k-sh/items/1e4d3ef8d10cc8271963#%E3%83%91%E3%83%83%E3%82%B1%E3%83%BC%E3%82%B8%E3%83%93%E3%83%AB%E3%83%89%E7%92%B0%E5%A2%83%E3%81%AE%E6%A7%8B%E7%AF%89

しかし、yum-utilsをインストールしようとしても以下のエラーが発生します。

# yum install yum-utils
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base-x86_64: ftp-srv2.kddilabs.jp
 * centosplus-x86_64: ftp-srv2.kddilabs.jp
 * epel: ftp.iij.ad.jp
 * epel-debuginfo: ftp.iij.ad.jp
 * epel-source: ftp.iij.ad.jp
 * extras-x86_64: ftp-srv2.kddilabs.jp
 * nux-dextop: mirror.li.nux.ro
 * updates-x86_64: ftp-srv2.kddilabs.jp
Resolving Dependencies
--> Running transaction check
---> Package yum-utils.noarch 0:1.1.31-46.el7_5 will be installed
--> Processing Dependency: python-kitchen for package: yum-utils-1.1.31-46.el7_5.noarch
--> Processing Dependency: libxml2-python for package: yum-utils-1.1.31-46.el7_5.noarch
--> Running transaction check
---> Package libxml2-python.armv7hl 0:2.9.1-6.el7_2.3 will be installed
--> Processing Dependency: libxml2 = 2.9.1-6.el7_2.3 for package: libxml2-python-2.9.1-6.el7_2.3.armv7hl
---> Package python-kitchen.noarch 0:1.1.1-5.el7 will be installed
--> Processing Dependency: python-chardet for package: python-kitchen-1.1.1-5.el7.noarch
--> Running transaction check
---> Package libxml2-python.armv7hl 0:2.9.1-6.el7_2.3 will be installed
--> Processing Dependency: libxml2 = 2.9.1-6.el7_2.3 for package: libxml2-python-2.9.1-6.el7_2.3.armv7hl
---> Package python-chardet.noarch 0:2.2.1-1.el7_1 will be installed
--> Finished Dependency Resolution
Error: Package: libxml2-python-2.9.1-6.el7_2.3.armv7hl (base)
           Requires: libxml2 = 2.9.1-6.el7_2.3
           Installed: libxml2-2.9.1-6.el7.3.armv7hl (@instCentOS/$releasever)
               libxml2 = 2.9.1-6.el7.3
           Available: libxml2-2.9.1-6.el7_2.3.armv7hl (base)
               libxml2 = 2.9.1-6.el7_2.3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 試したこと

前述のエラーの内容から推測すれば、 「libxml2-python-2.9.1-6.el7_2.3.armv7hl」のパッケージがないため失敗してしまうと考えました。

libxml2をインストールしようと以下のように実行しましたが...

# yum install libxml2
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base-x86_64: ftp.tsukuba.wide.ad.jp
 * centosplus-x86_64: ftp.tsukuba.wide.ad.jp
 * epel: ftp.iij.ad.jp
 * epel-debuginfo: ftp.iij.ad.jp
 * epel-source: ftp.iij.ad.jp
 * extras-x86_64: ftp.tsukuba.wide.ad.jp
 * nux-dextop: mirror.li.nux.ro
 * updates-x86_64: ftp.tsukuba.wide.ad.jp
Package matching libxml2-2.9.1-6.el7_2.3.armv7hl already installed. Checking for update.
Nothing to do


???
「libxml2-python-2.9.1-6.el7_2.3.armv7hl」がすでにインストールされています。
と出力するので、どうすればいいかわかりません。

ご回答のほどお待ちしております。

 前提環境

Raspberry Pi 3 Model B+
CentOS 7.4
microUSB 32G

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

yum-utils が libxml2-python を必要としていて、リポジトリに libxml2-python-2.9.1-6.el7_2.3.armv7hl があるけれど、実機には libxml2-2.9.1-6.el7.3.armv7hl がインストールされています。
libxml2 と libxml2-python のバージョンが合わないのでインストールできないようです。
base, updates リポジトリにある libxml2 の最新バージョンは 2.9.1-6.el7_2.3.armv7hl だと思います。
2.9.1-6.el7.3.armv7hl は base, updates リポジトリ以外からインストールしたのでしょうか?

(2018/08/29 00:36) 追記

libxml2-2.9.1-6.el7.3.armv7hl は 7.2 の updates にありました。
changelog を調べると、2.9.1-6.el7.3.armv7hl と 2.9.1-6.el7_2.3.armv7hl は同じもののようです。
なぜ、リリース番号が異なっているのかわかりませんが、現在(7.5) の base にある libxml2-python を使うには、同じバージョン・リリース番号の libxml2 が必要ですので、libxml2-2.9.1-6.el7_2.3.armv7hl に入れ替えるしかありません。

wget -N http://mirror.centos.org/altarch/7/os/armhfp/Packages/libxml2-2.9.1-6.el7_2.3.armv7hl.rpm
rpm -Uvh --oldpackage --test libxml2-2.9.1-6.el7_2.3.armv7hl.rpm
  (エラーがでなければ --test を省く)
rpm -Uvh --oldpackage libxml2-2.9.1-6.el7_2.3.armv7hl.rpm

yum install libxml2-python

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/28 23:45 編集

    回答ありがとうございます。
    >2.9.1-6.el7.3.armv7hl は base, updates リポジトリ以外からインストールしたのでしょうか?
    いえ、CentOS7をラズパイで初めて起動してネットワークにつないだ状態で最初に「yum install yum-utils」を実行しても上記のエラーが発生してしまいます。また、他のリポジトリを追加していない状態です。

    起動直後のリポジトリは以下のようになっております。
    # ls /etc/yum.repos.d/
    CentOS-armhfp-kernel.repo CentOS-Debuginfo.repo CentOS-Testing.repo
    CentOS-Base.repo CentOS-fasttrack.repo CentOS-Vault.repo
    CentOS-CR.repo CentOS-Sources.repo

    インストール可能なlibxml2パッケージを調べてみますと以下の通りです
    # yum --showduplicate list libxml2
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Installed Packages
    libxml2.armv7hl 2.9.1-6.el7.3 @instCentOS/$releasever
    Available Packages
    libxml2.armv7hl 2.9.1-6.el7_2.3 base

    キャンセル

  • 2018/09/01 19:40

    ありがとうございます。
    libxml2-2.9.1-6.el7_2.3.armv7hlにダウングレードしたことでインストールが成功しました

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.72%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる