質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.00%

CentOS5でLet’s Encryptを使いたい

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 2,272

TemmeiYamada

score 13

 前提・実現したいこと

CentOS5でLet’s Encryptを使いたい
が、前段階でつまづいています。。

 補足情報

CentOSバージョン5.11
サーバ:さくらの専用サーバ

 試したこと

CentOS5などの古い環境でLet’s Encryptを使う(2017/02/21更新)

こちらのページを参考にCentOS5でLet’s Encryptを入れようと思うのですが、
前段階でいろいろ障壁が出て困っています。

www root ~# git clone https://github.com/lukas2511/dehydrated.git
Cloning into 'dehydrated'...
fatal: unable to access 'https://github.com/lukas2511/dehydrated.git/': error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version


このようなエラーが出るので、調べるとgit、openssl、curl、sed、grepなどのバージョンが古いからかも、ということで、順番にgit、opensslをバージョンアップしました。

OpenSSL 1.0.2p  14 Aug 2018
git version 2.18.0

そしてcurl(curl-7.61.0.tar.gz)を入れようとすると
※PowerShellの文字化け直していません。。

www root /usr/local/src# wget https://curl.haxx.se/download/curl-7.61.0.tar.gz --no-check-certificate
--2018-08-27 12:08:43--  https://curl.haxx.se/download/curl-7.61.0.tar.gz
curl.haxx.se ��DNS���䤤���碌�Ƥ��ޤ�... 151.101.90.49, 2a04:4e42:15::561
curl.haxx.se|151.101.90.49|:443 ����³���Ƥ��ޤ�... ��³���ޤ�����
OpenSSL: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version
SSL �ˤ����³����Ω�Ǥ��ޤ���


このようなエラーが出て、ほかのバージョンアップも同様のエラーが出ます。
そこでopensslのバージョンを調べると、以前のものに戻っていました。

OpenSSL 0.9.8zg 11 Jun 2015

新旧が混在していることらしいですが、旧バージョンを完全に削除するのは良くないとも書かれていて、ここから先進めていない状態です。
※追記3の通り共有パスを追加したらopensslのエラーは消えたようです。

curlも手動でサーバからダウンロードFTPで/src/フォルダにアップロードしインストールしたらできました。

 これからどうしたいか

  • 最終的な目標はもちろんLet’s Encryptをインストールすること
  • 現状の解決(opensslの混在の解消、または混在のままcurlなどをアップデートしたい)(解消・下記追記参照)
  • ひょっとしてそれらをアップデートせずともLet’s Encryptをインストールできるのか

linuxなどほとんど分からずググって調べて見よう見まねでいじってますが、もうお手上げです。。
何卒よろしくお願いいたします。

 追記

1.OpenSSLのインストール
CentOS5でcurlしたら断られた
こちらの記事を参考にインストールしました。

# cd /usr/local/src
# wget https://www.openssl.org/source/openssl-1.0.2p.tar.gz --no-check-certificate
# tar xzvf openssl-1.0.2p.tar.gz
# cd openssl-1.0.2p
# ./config shared enable-ssl2 enable-ssl3 --prefix=/usr
# make depend
# make
# make test
# make install

2.cURLのインストール
wgetでエラーになるので、手動でダウンロード、FTPから/src/フォルダにアップロードして
インストールしたらできました。(この方法はまずいのでしょうか・・?)

3.共有ライブラリのパスに追加
OpenSSL のインストール
こちらを参考にopensslを共有ライブラリのパスに追加しました。
そうすると

OpenSSL: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version


このあたりのエラーは消えました。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • CHERRY

    2018/08/28 12:00 編集

    共有ライブラリのエラーがなくなってから、git を再度インストールしても同じエラーは出ますか?

    キャンセル

  • TemmeiYamada

    2018/08/28 12:20

    再度インストールしようとしたら、また最初のエラーが出ました。。。共有パスが上手く追加されてないということでしょうか。。。いつもこうやって堂々巡りです。。。涙

    キャンセル

  • CHERRY

    2018/08/28 12:29 編集

    ソースからのインストールは、configure コマンドを実行していると思います。 多くの場合は、configure コマンドが、自動的にライブラリを見つけてくれますが、同じ種類で複数ある場合等で、希望するものと違う方を利用する場合があります。 その場合は、configure にオプションを指定して、明示的に使用するライブラリのパスを与える必要があります。 ( configure --prefix=〜 --with-openssl=〜 のような感じでオプションを与えます。 )

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.00%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる