質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.13%

Raspberry Pi Zero WH 有線LANにてインターネットに繋がりません。

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 3,823

Guamstreet

score 31

Raspberry Pi Zero WHを、インターネットに繋げて、最終的にPCからWi-FiにてSSH操作したいです。
しかし、設定作業を行っている途中で、有線LANでのインターネット接続が全く繋がらず、そこから先に、一歩も進めない状況です。
yahoo質問してみたりしたのですが、具体的な解決策に至りません。

現在の状況:
(ググって下記作業をしました。尚、今回はヘッドレスでの作業です)
①SDにRaspbian_STRETCH_LITEをダウンロード。
②configの最下段に『dtoverlay=dwc2』追加。
③cmdlineを下記コードで書き換え。
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait modules-load=dwc2,g_ether quiet init=/usr/lib/raspi-config/init_resize.sh
④raspi-configにてパーテーション拡大、タイムゾーン等、一通りの一般設定実施。
⑤OTGドライバー、Bonjourをダウンロード。
⑥デバイスマネージャ、ネットワークアダプターにて、Gadget表示の確認。
⑦家のインターネットルーターと、⑥のGadgetを共有。
⑧Tera TermをWindows10にダウンロード。
⑨Tera TermにてSSH接続し、接続は上手く行きました。
⑩ifconfigにて状況確認(下記)

pi@raspberrypi:~ $ ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
inet 127.0.0.1  netmask 255.0.0.0
inet6 ::1  prefixlen 128  scopeid 0x10<host>
loop  txqueuelen 1000  (ローカルループバック)
RX packets 278  bytes 26410 (25.7 KiB)
RX errors 0  dropped 0  overruns 0  frame 0
TX packets 278  bytes 26410 (25.7 KiB)
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
inet 169.254.144.218  netmask 255.255.0.0  broadcast 169.254.255.255
inet6 fe80~○○○  prefixlen 64  scopeid 0x20<link>
ether 2a~○○○  txqueuelen 1000  (イーサネット)
RX packets 437  bytes 60854 (59.4 KiB)
RX errors 0  dropped 0  overruns 0  frame 0
TX packets 488  bytes 53521 (52.2 KiB)
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
ether b8:27:eb:ce:7a:10  txqueuelen 1000  (イーサネット)
RX packets 0  bytes 0 (0.0 B)
RX errors 0  dropped 0  overruns 0  frame 0
TX packets 0  bytes 0 (0.0 B)
TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

上記のように、インターネットに繋がっていない状況です。
これの対応策を、ご教示頂きたく、どうぞよろしくお願い致します。

ちなみに、いろいろなサイトには、有線の表示については『eth0』と表示されているのに対して、私のは『usb0』と表示されます。
これはなぜですか?
あと、Raspberry Pi Zero WHに接続するマイクロUSBは、電源の方ではなく、USBの方のコネクタに挿しています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

Guamstreetさん、

"有線LAN接続"というと、ふつうは、RJ-45コネクタの口にケーブルを挿すものをいうので、
ここで言われてるのは、USBケーブルでホストPCに接続・経由してネットワークを使用する、ということになります。(後者も有線ですけど有線USB???かな。USBは基本、有線ですが..)

なので、"PiZeroで有線LAN接続"、なんかで検索すると、USBネットワークアダプタを使用した記事がたいてい出てくるんじゃないかと思います。

ここでやってるのは、PiZeroをUSBデバイスのEthetnet gadget(USBイーサネット・ガジェット, g_ether)として設定してるので、eth0でなくusb0というデバイスになってますね。

⑨Tera TermにてSSH接続し、接続は上手く行きました。

とのことなので、USBガジェットとしての設定は大丈夫だと思いますので、

  • ラズパイのGatewayやルーティングの設定の確認
  • Windowsのファイアウォールの設定
  • インターネット共有は、インターネットにつながってるネットワークアダプタのプロパティ(R)を開いて、[共有]タブを選んで、"インターネット接続の共有"で、有効にしているか。

あたりかと思います。確認してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/31 03:47 編集

    Guamstreetさん、

    (Windowsの設定を変更していなければ..) インターネット共有を使うと、共有したアダプタのIPに192.168.137.1がたいてい設定されるので、そのあたりの設定がうまくいってなさそうな気がします。

    - インターネットに接続しているアダプタのプロパティを開いて、[共有]タブで、チェックを入れる
    - ipconfigの出力見ると、ネットワークアダプタが複数あるようなので、インターネットに接続したいアダプタを選択するプルダウンメニューがでてきてると思います。そこで、PiZeroのアダプタを選択する。
    - とりあえず、設定したら、再起動。

    で、ラズパイのアダプタのアドレスが、192.168.137.1になってたか、ipconfigで確認してみてください

    キャンセル

  • 2018/08/31 09:29

    mt08さん、早速のご返信、感謝です!
    アドバイス、ほんとにありがとうございます!
    今、外出中なので、帰りましたらすぐにやってみます!
    また、ご報告申し上げます!
    いろいろと、ありがとうございます!

    キャンセル

  • 2018/09/02 03:56

    mt08さん、ご連絡、遅くなりまして大変申し訳ありません。
    外出から戻り、前回のアドバイスを頂いた内容で、今までやってみましたところ、結果から言って、USB有線にて、Raspberry Pi Zero Wのインターネット接続をする事が出来ました。

    しかしながら、これについては、限定条件がありまして、実は、我が家には、2つPCがあります。
    ともにWZR-HP-AG300H(うちの無線ルーター)で、同じ無線LAN内のPCです。

    で、このうちの1台のほうで、今まで、いろいろな試みをやってきました。
    どうやっても無理で諦めかけた時に、『んっ!?待てよ、もう一台のほうのPCでも同じ現象が起きるのか?』という、単純な疑問が湧きました(もう少し早く気づいても良さそうなものですが(^_^;))

    それで、もう一台のほうのPCで、まったく同じ操作の設定をしたところ、あっさりとRaspberry Pi Zero Wを有線にてインターネットに接続させる事ができました。


    ①Raspberry Pi Zero WをネットワークアダプタとしてPCに認識させ、ゲートウエイルーターWZR-HP-AG300H(うちの無線ルーター)と共有させる。

    ②次にTera TermでSSH接続&pingを打つ。

    以上の、まったく同じ内容です。
    これを、もう一つのPCにて実施したところ、有線にてRaspberry Pi Zero W、インターネット接続させる事ができました。

    有線接続できて、めでたし、めでたし、なのですが、どうして片方のPCで出来て、片方では出来ないのかの疑問が残ります。

    これについて、もし、何かヒントを頂けるなら、非常に嬉しいですが、今回の質問の内容から、方向が少々ずれてしまう感じがするので、これ以降、お付き合いしてくださるかどうかは、mt08さんの判断で、全然構いません。

    ここまで、いろいろとアドバイスくださり、ほんとうにありがとうございました!

    私は、引き続き『なぜ片方のPCで出来て、片方のPCではできないか?』を、突き止めて参りたいと思います!

    この質問に、今回のこの件を補足しまして、引き続き、有益な情報が頂けるようにしていきたいとおもいます!

    キャンセル

0

参考情報

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/29 08:37

    ご回答下さいましてありがとうございました!
    また、ご返信するの遅れました事、大変、申し訳ありません。
    早速、上記の参考サイトを見させていただきました。
    今まで、いろいろとググって参りまして、これは、既に私も見ていたサイトでした。
    しかし、もう一度、良く読み返してみましたところ、適切なusbケーブルを使わないと行けないと、あたりまえですが、その様にうたっている下りがありました。
    もしかしたらkatoyさんは、この事を私に伝えたかったのかと思いまして、改めて、そのところにフォーカスしまして、家にあるものではなく、もう少し構成なものを、Amazonで注文いたしまして、それの到着を待っているところです。
    到着したら早速、そのケーブルで、有線でインターネットが繋がるか、やってみます。
    そして、その結果をご報告させていただきます。
    それまで、少々お待ちください。
    ご回答くださいまして、どうもありがとうございます!

    キャンセル

  • 2018/08/29 21:47

    katoyさん、本日、Amazonよりケーブルが届きまして、改めて接続しなおしてやりましたところ、やはり状況は変わりませんでした。
    もう少し、勉強してみます。
    せっかく、アドバイスいただいたのに、すいません。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる