質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.13%

コンパイラをダウンロードして、利用できるように設定したい

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 998

score 196

環境

  • Arduino 1.8.5
  • macOS High Sierra 10.13.6

知りたいこと

Arduino 1.8.5 にて、Arduino Uno 向けのコンパイラを入手したいのですが、
どこからダウンロードすればよろしいでしょうか?

解決したいこと

Arduino Studio からのコンパイル時に発生する、下記エラーを解決しようとしています。
メッセージから察するに、コンパイラが壊れているように思えます。

Arduino:1.8.5 (Mac OS X), ボード:"Arduino/Genuino Uno"

fork/exec /Users/hoge/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++: no such file or directory
ボードArduino/Genuino Unoに対するコンパイル時にエラーが発生しました。

「ファイル」メニューの「環境設定」から
「より詳細な情報を表示する:コンパイル」を有効にすると
より詳しい情報が表示されます。

試したこと

ls コマンドでコンパイラを探してみましたが、見つかりませんでした。

➜  ~ ls /Users/shusuke/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++
ls: /Users/shusuke/Library/Arduino15/packages/arduino/tools/avr-gcc/4.9.2-atmel3.5.4-arduino2/bin/avr-g++: No such file or directory
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • y_waiwai

    2018/08/26 10:36

    ArduinoStudioでコンパイルできませんか?

    キャンセル

  • sutonea

    2018/08/26 10:44

    エラーメッセージは、ArduinoStudioでコンパイルした際に表示されています。その旨、質問本文へ追記いたしました。

    キャンセル

回答 1

checkベストアンサー

0

ArduinoStudioにはいってませんか?


ArduinoStudio を改めて入れ直してみてもダメでしょうか?

AVRのGCCツールチェインはあるようですが、それを個別に入れてもArduinoで使えるようになるのかどうか。

#回答書き込んだらサーバエラーになったんでコメントに書込んでとやったら両方書かれてました

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/26 12:04

    > Arduino AVR Borads by Arduino というのがツールチェインだと思うんですが、それがINSTALLDになってないでしょうか。

    1.6.21 が INSTALLED となっていました。

    > そこでバージョンを選んでインストールしたら、ツールチェインがインストールされないでしょうか。

    試しに 1.6.20 を選んでインストールしてみました。
    その後、問題なくコンパイルすることができました。
    ありがとうございます!

    キャンセル

  • 2018/08/26 12:07

    こちらでも1.6.21 でINSTALLD になってます。
    それがダメ、というのは不思議ですね。。

    キャンセル

  • 2018/08/26 13:04

    1.6.20 が INSTALLED の状態で、
    ボードマネージャから 1.6.21 を選択してインストールしてみました。

    結果、正常に動作していました。
    上記操作により、1.6.21が正しくインストールされたのだと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る