質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.38%

  • RubyGems

    376questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

railsの新アプリケーションにscaffoldをbundleしようとしてのエラー

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 153

hokosugi

score 35

 解決したいエラー

cloud9でcarrierwaveを試すために簡単な新規アプリケーションを作成する際にエラーが出ます。

//新規アプリケーション立ち上げ
ec2-user:~/environment $ rails _4.2.6_ new testcarrierwave -d mysql
//gemfileにscafflodを追加
gem 'scaffold'
//bundle install
ec2-user:~/environment/testcarrierwave $ bundle install
//rake db:migrate
ec2-user:~/environment/testcarrierwave $ rake db:migrate
rake aborted!
LoadError: cannot load such file -- puppet


ここで検索してpuppetをインストールするべきと書いてあったので

gem install puppet
//再度rake db:migrate
ec2-user:~/environment/testcarrierwave $ rake db:migrate
rake aborted!
LoadError: cannot load such file -- puppet


変化がありません。
ここでお手上げになってしまいました。
エラーログ全文です。

rake aborted!
LoadError: cannot load such file -- puppet
/usr/local/rvm/gems/ruby-2.3.1/gems/scaffold-0.0.3/lib/scaffold.rb:5:in `require'
/usr/local/rvm/gems/ruby-2.3.1/gems/scaffold-0.0.3/lib/scaffold.rb:5:in `<top (required)>'
/usr/local/rvm/gems/ruby-2.3.1/gems/bundler-1.16.3/lib/bundler/runtime.rb:81:in `require'
/usr/local/rvm/gems/ruby-2.3.1/gems/bundler-1.16.3/lib/bundler/runtime.rb:81:in `block (2 levels) in require'
/usr/local/rvm/gems/ruby-2.3.1/gems/bundler-1.16.3/lib/bundler/runtime.rb:76:in `each'
/usr/local/rvm/gems/ruby-2.3.1/gems/bundler-1.16.3/lib/bundler/runtime.rb:76:in `block in require'
/usr/local/rvm/gems/ruby-2.3.1/gems/bundler-1.16.3/lib/bundler/runtime.rb:65:in `each'
/usr/local/rvm/gems/ruby-2.3.1/gems/bundler-1.16.3/lib/bundler/runtime.rb:65:in `require'
/usr/local/rvm/gems/ruby-2.3.1/gems/bundler-1.16.3/lib/bundler.rb:114:in `require'
/home/ec2-user/environment/testcarrierwave/config/application.rb:7:in `<top (required)>'
/home/ec2-user/environment/testcarrierwave/Rakefile:4:in `require'
/home/ec2-user/environment/testcarrierwave/Rakefile:4:in `<top (required)>'
/usr/local/rvm/gems/ruby-2.3.1/gems/rake-12.3.1/exe/rake:27:in `<top (required)>'
/usr/local/rvm/gems/ruby-2.3.1/bin/ruby_executable_hooks:24:in `eval'
/usr/local/rvm/gems/ruby-2.3.1/bin/ruby_executable_hooks:24:in `<main>'
(See full trace by running task with --trace)


手がかりかアドバイスがありましたら(出来れば解決策)宜しくお願いします。

 補足情報

ruby: 2.3.1 p122
rails: 4.2.6
scaffold: 0.0.3

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

gem 'scaffold'をアンインストールしたら正常に動きました。大変失礼しました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

scaffoldはgemではないのですね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.38%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • RubyGems

    376questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。