質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.21%

bundler install で Network error while fetching というエラーが出る

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 968

gano

score 12

 前提・実現したいこと

bundle install で chefをインストールしたい

OSは Mac OS Xを使っています。

 発生している問題・エラーメッセージ

Gemfile に gem 'chef'と記述し、
bundle install すると以下のエラーが出ます。

Network error while fetching
https://rubygems.org/quick/Marshal1.4.8/chef-14.3.37.gemspec.rz (exection expired)

 試したこと

1. URLを直接ブラウザに貼り付けてみる

Network errorと出てるので、接続を確かめるため、
ブラウザに以下のURLを直接貼り付ける。
https://rubygems.org/quick/Marshal1.4.8/chef-14.3.37.gemspec.rz

結果、rzファイルが普通にダウンロードできる

2. bundlerのアップグレード/ダウングレード

以下3つのバージョンで試して見ましたが変化無し

1.16.3 (最新版)
1.16.2
1.15.4

3.別のOSでやってみる

Ubuntu で bundle install してみたらうまくいきました。
なぜMacではうまくいかないのかわからない状態です。。。

4.chef以外のライブラリをインストールしてみる

Macのbundlerがおかしいのだと判断し、
Mac で nokogiri をインストールしてみます。

gem 'nokogiri' をGemFileに記述し、
bundle install してみたらこちらは成功。

bundler自体は正常に思えます。。。

5.ネットワークの確認

MacもUbuntuも同一ネットワークで、
特にProxy等も利用していない状態です。。。

6.GitHubリポジトリからclone

https://github.com/chef/chef からchefをcloneして、
インストールしようと思ったのですが、
途中で bundle install が必要となり、同様のエラーがでます。。。

 質問

rubygems.org側の問題かと思ったのですが、ubuntuではインストールできまして、、
次はMacのせいだと思ったのですが、Macのbundlerは他のライブラリはインストールできました。。

Macのbundlerだけがchefと相性悪いなんていうことがありますでしょうか。。。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

うーん、普通にGemfileに、

source "https://rubygems.org"

gem "chef"

と書いて、bundle installするとインストールできるかと思う(私の環境ではできた)のですが。

ちなみにRubyのバージョンはいくつですか?(2.5.0か2.5.1がおすすめです)

それともしsource "https://rubygems.org"の行が抜けてたんでしたら、それを加えて試してもらえますか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/13 09:26

    ネットワークを自宅Wifiから4Gに切り替えたらなぜかインストールできました。。。

    自宅ネットワーク特有の問題かと思ったのですが、
    それですと、Ubuntuで正常に動作することが説明つかず、、、

    記憶にないのですが、Macに何かしらネットワーク設定しているのかな と思ったのですが、
    Mac固有の問題であれば、ネットワークを切替えてもダメなはずなので、、、

    自宅ネットワークとMacの相性が悪い(?) という謎の切り分けに至っております。。。

    ご回答いただきましてありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる