質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.58%

サーバの立ち上げでエラーが発生する

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 724
退会済みユーザー

退会済みユーザー

 前提・実現したいこと

エラーをなくして,サーバーを正常に立ち上げたい.

 発生している問題・エラーメッセージ

現在,下記のコマンドでuwsgi,nginxなどを立ち上げています.

screen -c .screenrc 


すると,下のようなエラー文が出てきます.

dyld: Library not loaded: @rpath/libexpat.1.dylib
  Referenced from: /Users/{user_name}/.pyenv/versions/anaconda3-5.1.0/bin/uwsgi
  Reason: Incompatible library version: uwsgi requires version 8.0.0 or later, but libexpat.1.dylib provides version 7.0.0
sh: line 1: 16748 Abort trap: 6           uwsgi --ini local/uwsgi/uwsgi.ini
=== Window terminated (Sat Aug 11 11:05:23 2018) ===

 試したこと

terminalで下記のコマンドを入力しexpatの更新をしましたが,エラー文が変わりませんでした.

$ brew install expat 

 補足情報(FW/ツールのバージョンなど)

ハードはMacBook Pro (13-inch, 2016, Two Thunderbolt 3 ports)
OSはmacOS High Sierra(Version 10.13.7)です.

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • CHERRY

    2018/08/11 11:38

    `expatの更新をしようとしましたが失敗しました` のログを記載してもらえないでしょうか?

    キャンセル

  • 退会済みユーザー

    退会済みユーザー

    2018/08/11 11:46

    すみません,言い方を間違えました.「expatの更新をしたが,エラー文が変わりません」と訂正します.

    キャンセル

  • CHERRY

    2018/08/11 11:55

    バージョン8が、必要と言っていますが、いくつが入っているのでしょうか?

    キャンセル

  • 退会済みユーザー

    退会済みユーザー

    2018/08/11 12:09 編集

    libexpatは-V, -v, --versionを末尾につけて調べたのですが,バージョンが出てきません. expatは"brew install expat"でインストールしたところ,は2.2.5です.

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.58%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る