質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.07%

rbenv、Rubyのダウンロード・インストールについて

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 651

soft_admin

score 59

 前提・実現したいこと

Rubyを勉強しようと思い、PCに入れようとしています。
windows10のPCにUbuntuを入れて、そこから以下のようにコマンドを投げています。

$ sudo yum -y install git

$ git clone https://github.com/sstephenson/rbenv.git ~/.rbenv

$ echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.bash_profile

$ echo 'eval "$(rbenv init -)"' >> ~/.bash_profile

$ exec $SHELL -l

$ rbenv --version

$ git clone https://github.com/sstephenson/ruby-build.git ~/.rbenv/plugins/ruby-build

$ rbenv install --list

$ rbenv install 2.4.1     ※Rubyの教本のバージョンが2.4.1であるため。

$ rbenv rehash

$ rbenv versions

$ rbenv global 2.4.1

$ ruby -v


この流れで上手くいったように見えるのですが、Ubuntuを閉じてもう一度開いた後に、

$ ruby -v


とコマンドを投げると、

プログラム 'rbenv' はまだインストールされていません。 次のように入力することでインストールできます:
apt install rbenv


と出力されます。ディレクトリには確かにrbenvのファイルなどはあるのですが、どういうことなのでしょうか?
きちんとrbenvとRubyはインストールされているのでしょうか?
よろしくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

https://qiita.com/kure/items/d45dd7acf76294296f02
などにかいてある手順を試してみてください。

git clone ... でいれているのは rbenv という 複数の ruby の version を管理するためのツールです。 
この後に、使いたい version の ruby をインストールする必要があります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/11 12:56

    できました!
    rbenvやLinuxコマンドについてもいろいろ調べてみようと思います。
    本当にありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.07%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る