質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.34%

Windows上のvagrantでIPアドレスが設定できない

受付中

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 2,124
退会済みユーザー

退会済みユーザー

Windows7にVirtualBox5.2.14+Vagrant2.1.2をインストール。
VirtualBoxに仮想環境でCentOS7を構築。
構築したCentOS環境をBOXにし、Vagrant box add で環境追加を行った。
vagrant box listで追加されているのを確認。
vagrant initでvagrantfileを生成した。

この生成したvagrantfile内の
# config.vm.network "private_network", ip: "192.168.33.10"
のコメントをはずし
config.vm.network "private_network", ip: "192.168.33.10"
とした上で
vagrant upを実行。
C:\var\myvagrant\rt1>vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Clearing any previously set forwarded ports...
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
default: Adapter 1: nat
default: Adapter 2: hostonly
==> default: Forwarding ports...
default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
default: SSH address: 127.0.0.1:2222
default: SSH username: vagrant
default: SSH auth method: private key
と表示される。

default: SSH address: 127.0.0.1:2222

default: SSH address: 192.168.33.10:2222
となるのを期待していましたが、vagrant ssh-configで確認しても
Host default
HostName 127.0.0.1
User vagrant
Port 2222
UserKnownHostsFile /dev/null
StrictHostKeyChecking no
PasswordAuthentication no
IdentityFile C:/Users/ast/.vagrant.d/insecure_private_key
IdentitiesOnly yes
LogLevel FATAL
となって「127.0.0.1」のままです。

何か他に設定しなければならないこととかがあるのでしょうか?
ご教授お願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

ローカルのLANに参加させるなら、VirtualBoxのネットワーク設定で、NATではなく、ブリッジにする必要があります

#Vagrantでそれが可能かどうかはわかりませんが

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/06 16:17

    >ネットワーク設定はブリッジになってるんでしょうか
    すみません、どこを見れば「ブリッジアダプターである」とわかるでしょうか?

    キャンセル

  • 2018/08/06 16:26

    VirtualBox起動して設定>ネットワーク

    キャンセル

  • 2018/08/06 16:31

    「NAT」のままでした。


    vagrant upz時の表示内容も
    Bringing machine 'default' up with 'virtualbox' provider...
    ==> default: Importing base box 'router4'...
    ==> default: Matching MAC address for NAT networking...
    ==> default: Setting the name of the VM: rt1_default_1533540569658_3114
    ==> default: Clearing any previously set network interfaces...
    ==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    ==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
    となって、NATのままのようです。残念。

    キャンセル

0

現在は、ポートフォワーディングされている状態ですね。

config.vm.network "private_network"

を config.vm.network "public_network" に変更したら ホストPC と同じ LAN 側ネットワークの IP アドレスを設定できるようになるので、直接アクセスできると思います。

vagrant ネットワーク設定の違いについては、vagrantのネットワークについて が、わかりやすいのではないでしょうか。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/06 16:14

    config.vm.network "private_network", ip: "192.168.33.10"
                  ↓
    config.vm.network "public_network", ip: "192.168.33.10"

    config.vm.network "private_network", ip: "192.168.33.10"
                  ↓
    config.vm.network "public_network"
    のように修正してみましたが、いずれも表示は
    ==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    のままでした。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る