質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.91%

【Ubuntu】Makeを使ってインストールしようとするとエラーになる

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 3,606

sum52154

score 9

QRadioPredictというソフトをUbuntu16.04にインストールしたい

QRadioPredictというソフトをUbuntu16.04にインストールしたいです。

https://github.com/QDeltaSoft/qradiopredict
を参考にしました。

$ apt-get install gdal-bin libgdal1i libgdal1-dev libgeos-dev libsqlite3-0 libboost-all-dev

$ apt-get install gdal-bin libgdal1 libgdal1-dev libgeos-3.3.3 libgeos-dev libsqlite3-0

$ git clone https://github.com/QDeltaSoft/qradiopredict.git qradiopredict
$ cd qradiopredict
$ mkdir build
$ cd build
$ qmake-qt4 ..
$ make


をやるみたいです。

 試したこと

$ apt-get install gdal-bin libgdal1i libgdal1-dev libgeos-dev libsqlite3-0 libboost-all-dev
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
libsqlite3-0 はすでに最新バージョン (3.11.0-1ubuntu1) です。
gdal-bin はすでに最新バージョン (1.11.3+dfsg-3build2) です。
libboost-all-dev はすでに最新バージョン (1.58.0.1ubuntu1) です。
libgdal1-dev はすでに最新バージョン (1.11.3+dfsg-3build2) です。
libgdal1i はすでに最新バージョン (1.11.3+dfsg-3build2) です。
libgeos-dev はすでに最新バージョン (3.5.0-1ubuntu2) です。
アップグレード: 0 個、新規インストール: 0 個、削除: 0 個、保留: 0 個。


は問題ありませんでした。

$ apt-get install gdal-bin libgdal1 libgdal1-dev libgeos-3.3.3 libgeos-dev libsqlite3-0

Working... this may take a while.
E: パッケージ 'libgdal1' にはインストール候補がありません
E: パッケージ libgeos-3.3.3 が見つかりません
E: 'libgeos-3.3.3' に一致するパッケージは見つかりませんでした
E: 正規表現 'libgeos-3.3.3' ではパッケージは見つかりませんでした
Package manager quit with exit code.
$ git clone https://github.com/QDeltaSoft/qradiopredict.git qradiopredict
$ cd qradiopredict
$ mkdir build
$ cd build
$ qmake-qt4 ..
$ make
cd MapGraphics/ && make -f Makefile 
make[1]: ディレクトリ '/home/student/qradiopredict/build/MapGraphics' に入ります
/usr/lib/x86_64-linux-gnu/qt4/bin/uic ../../MapGraphics/guts/CompositeTileSourceConfigurationWidget.ui -o ui_CompositeTileSourceConfigurationWidget.h
make[1]: /usr/lib/x86_64-linux-gnu/qt4/bin/uic: コマンドが見つかりませんでした
Makefile:391: ターゲット 'ui_CompositeTileSourceConfigurationWidget.h' のレシピで失敗しました
make[1]: *** [ui_CompositeTileSourceConfigurationWidget.h] エラー 127
make[1]: ディレクトリ '/home/student/qradiopredict/build/MapGraphics' から出ます
Makefile:40: ターゲット 'sub-MapGraphics-make_default' のレシピで失敗しました
make: *** [sub-MapGraphics-make_default] エラー 2

QRadioPredictに限らず、
このようなエラーに遭遇したときどのように対応するのが良いのでしょうか。
エラーの原因・解決方法
など教えていただけたら幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

ちゃんとドキュメントを読みましょう。あなたが失敗したといっているapt-getコマンドはDebian用であってubuntu用ではありません。ライブラリ等のインストールは最初のapt-getで終わっています。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/03 09:23

    ありがとうございます

    makeで失敗したりエラーが出たりした場合の対処法はどのようにすればいいでしょうか?

    キャンセル

  • 2018/08/03 21:07

    何かが足りていないので、足りていないものが何かを見極めて補いましょう。エラーメッセージで「xxがない」と言われています。ちょっと調べたらそれがどこで提供されているものかがわかります。必要なパッケージを探し出して追加インストールをかけましょう。

    お手本にしているドキュメントの筆者の環境には元から入っているが、あなたの環境にはなくて自分で別途インストールしなければならないライブラリやツールがあるなどという状況は、普通にあり得ることです。臨機応変に対応する必要があります。

    キャンセル

  • 2018/08/04 10:01

    ありがとうございます
    /usr/lib/x86_64-linux-gnu/qt4/bin/uic
    で検索してみたところ、
    https://github.com/openscad/openscad/issues/1308

    libqt4-dev
    が必要のようなことが書いてあったので、
    apt-get install libqt4-dev
    と実行し、
    再度
    make
    したら
    解決しました!

    エラーメッセージをよく読んで
    必要なパッケージを探し出して追加インストール
    すれば良いのですね。
    次からは対応できそうです。
    ありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.91%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る