質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

  • Ruby

    8172questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7663questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

bundlerが古いと言われる

受付中

回答 4

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 205

on_off_on

score 12

railsコマンドを実行しようとすると、何個も抜けてるgemがあり、次々とgemのインストールの指示がでます。

よく見るとbundle installした際に

Warning: the running version of Bundler (1.16.1) is older than the version that created the lockfile (1.16.3). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

と出ていて、どうやらbundlerのバージョンが古いことが原因っぽいです。

しかしgem install bundlerを打っても、gem install bundler -v 1.6.3を打っても何も変わらないです。

この場合は何がおかしいんでしょうか?

ちなみにgem listではbunlder(1.16.3)がでます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 4

0

gem update bundler


を実行するとどうでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/23 08:27 編集

    回答ありがとうございます。
    Nothing to updateと出てしまいます。。
    ちなみにgem listではbunlder(1.16.3)がでます。

    キャンセル

  • 2018/07/23 13:36

    ```
    bundle update
    ```
    してから
    ```
    bundle install
    ```
    するとどうでしょうか?

    Gemfile.lock の最後に以下のような記述があって、それが影響しているのでは?と予想しています。
    ```
    BUNDLED WITH
    1.16.1
    ```

    ただ、 `bundle update` すると gem によっては動かなくなってしまうので、現状を git などで保存してから実行した方がいいかもしれません。

    キャンセル

  • 2018/07/23 14:09

    bundle updateの時点で質問文に載せたものと同じエラーメッセージが出ます。

    情報が小出しになってしまってすみません。
    整理すると、gem listでは、1.16.3が出るのにbundle -vでは1.16.1が出る。
    よってbundle installした際に使われるbundlerは1.16.1になる。
    でもGemfile.lockに記載されているBUNDLED WITHは1.16.3だから古いよと言われる。

    という状況になってます.

    キャンセル

  • 2018/07/23 14:15

    うーん...
    rails で使っている bundler とPCで使っている bundler のバージョンの違いが影響してるんですかね?
    ちょっとその辺は僕もあまり強い方ではなく...

    `bundle install` はこのコマンドのままでしょうか?
    `bundle install --path vendor/bundle` にして、rails コマンドの実行を `bundle exec rails s` とかにするとどうでしょう?

    キャンセル

  • 2018/07/23 20:01

    提案ありがとうございます。
    教えていただいたコマンドの意味を調べて理解してから試してみますね。

    キャンセル

0

... We suggest you upgrade to the latest version of Bundler by running gem install bundler. ...

まずは、これを日本語に訳してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

シェル等から
ruby -rbundler/cli -e"Bundler::CLI.start(ARGV)" -- -v
を実行するとBundler version 1.16.3が表示されますでしょうか?

もし、1.16.3が表示されていた場合
which bundle windowsの場合はwhere bundleコマンドで
bundleコマンドがどこのbundleコマンドなのかを確認した方がよいです

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/23 20:00

    ありがとうございます。
    bundleコマンドは/usr/local/bin/bundleにあるようですが、そこからどうしていいかわかりません。。

    初歩的で申し訳ありませんが、ヒントだけでもいただけると嬉しいです。

    キャンセル

  • 2018/07/23 20:07

    rbenv rehashしてみる とか
    PATH設定を見直してみるとかですかね

    キャンセル

0

Gemfileでbundlerのバージョンが(1.16.1に)指定されていたりしませんか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • Ruby

    8172questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7663questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。