質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Python 3.x

    6451questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

python 3系のインストールについて

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 112

kooo789

score 2

 前提・実現したいこと

python3系が使えるように設定変更したいです

 発生している問題・エラーメッセージ

ProgateのPythonの開発環境を用意しよう!(Mac)(https://prog-8.com/docs/python-env)というページを見ながら、
インストールをしたのですが最後のversionの確認をしたところ2系のままでした。
指示通りやって3.6.5のversionはインストール出来ていると思います。
どこを直したら良いでしょうか?

### 該当のソースコード

ここに言語名を入力
ソースコード
```

 試したこと```!

ここに問題に対して試したことを記載してください。

 補足情報(FW/ツールのバージョンなど)イメージ説明

ここにより詳細な情報を記載してください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

~/.bash_profileに次を追加してみてください。

export PATH="/Users/username/.pyenv:$PATH"
eval "$(pyenv init -)"

下記のところを参考にしてやってみところ、私の環境ではうまく動くようになりました。
https://github.com/pyenv/pyenv/issues/821#issuecomment-287721994

MBP - High Sierra

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/23 21:49

    できました。ありがとうございます。

    キャンセル

+1

とりあえずググったらこんなのが出てきました。該当するかどうかはわかりませんが、貼っておきます。

pyenv globalで切り替わらない!

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/23 21:49

    できました。ありがとうございます。

    キャンセル

+1

python3系をつかうのが目的でしたらPython official pageからダウンロードするのもアリだと思います。
そちらの方が断然簡単ですよ。

また、Python3のバージョンを確認する際はpython3 --versionとしましょう。
python --versionではありません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/23 21:49

    できました。ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.51%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    PyCharmとGitLabの連携方法について

    PyCharm2017.1 を使っております https://plugins.jetbrains.com/plugin/7319-gitlab-integration 上記のG

  • 解決済

    PyQtにおけるQWidgetとQGraphicsViewの組み合わせ

    http://d.hatena.ne.jp/mFumi/20141112/1415806010 このサイトをお手本にQWidgetとQGraphicsViewの組み合わせを実

  • 解決済

    回答ありがとうございました

    質問消せないようなので問題文は 消させていただきます 回答ありがとうございました

  • 解決済

    IntelliJ IDEA でKotlinの実行ができない

    実現したいこと IntelliJ IDEAで Kotlinのプログラムを実行したいです。 しかしエラーが表示されてしまいます。 ソースコード package sampl

  • 解決済

    Python ImportError エラー

    http://qiita.com/ynakayama/items/2cc0b1d3cf1a2da612e4 このサイトの通りに進めているのですが、エラーが出てしまいます。

  • 解決済

    vim-flake8を導入した際エラー行の色を変えたい

    実現したいこと macのデフォルトターミナル(novel)上でvimを開き、 nvie/vim-flake8のプラグインを導入しました。 F7を押すとpep8違反となる行を表

  • 解決済

    vb2017でexcel2016操作

    vb2017を使っています。 communityです。 excel2016を開いてセルのデータを読み込みたいと思っています。 参考にしているサイトです。 http://d.

  • 受付中

    matplotlibでの軸ラベルのフォント

    matplotlibを用いてグラフの描画をしたいと思っています。 そこで、軸ラベルのフォントをアルファベットの場合にはArial, ギリシャ文字の場合にはSymbolと使い分けたい

同じタグがついた質問を見る

  • Python 3.x

    6451questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。