質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.51%

  • Ruby on Rails

    7298questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

railsが起動しなくなってしまいました

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 171

Lala..

score 0

railsが起動しなくなっていました。
このようなエラーが出るのですがどうしたら良いでしょうか?

エラーメッセージ


/Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in require': dlopen(/Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/mysql2-0.5.2/lib/mysql2/mysql2.bundle, 9): Library not loaded: /usr/local/opt/mysql/lib/libmysqlclient.21.dylib (LoadError)   Referenced from: /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/mysql2-0.5.2/lib/mysql2/mysql2.bundle   Reason: image not found - /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/mysql2-0.5.2/lib/mysql2/mysql2.bundle     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in block in require_with_bootsnap_lfi'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in register'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in require_with_bootsnap_lfi'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in require'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in block in require'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:249:in load_dependency'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in require'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/mysql2-0.5.2/lib/mysql2.rb:33:in <main>'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in require'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in block in require_with_bootsnap_lfi'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in register'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in require_with_bootsnap_lfi'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in require'
from /Users/maple002/.rbenv/versions/2.3.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.2/lib/bundler/runtime.rb:81:in block (2 levels) in require'     from /Users/maple002/.rbenv/versions/2.3.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.2/lib/bundler/runtime.rb:76:in each'
from /Users/maple002/.rbenv/versions/2.3.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.2/lib/bundler/runtime.rb:76:in block in require'     from /Users/maple002/.rbenv/versions/2.3.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.2/lib/bundler/runtime.rb:65:in each'
from /Users/maple002/.rbenv/versions/2.3.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.2/lib/bundler/runtime.rb:65:in require'     from /Users/maple002/.rbenv/versions/2.3.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.2/lib/bundler.rb:114:in require'
from /Users/maple002/Desktop/kaosaiyou/config/application.rb:7:in <main>'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in require'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in block in require_with_bootsnap_lfi'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in register'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in require_with_bootsnap_lfi'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in require'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in block in require'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:249:in load_dependency'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in require'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/railties-5.2.0/lib/rails/commands/server/server_command.rb:145:in block in perform'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/railties-5.2.0/lib/rails/commands/server/server_command.rb:142:in tap'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/railties-5.2.0/lib/rails/commands/server/server_command.rb:142:in perform'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/thor-0.20.0/lib/thor/command.rb:27:in run'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/thor-0.20.0/lib/thor/invocation.rb:126:in invoke_command'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/thor-0.20.0/lib/thor.rb:387:in dispatch'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/railties-5.2.0/lib/rails/command/base.rb:65:in perform'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/railties-5.2.0/lib/rails/command.rb:46:in invoke'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/railties-5.2.0/lib/rails/commands.rb:18:in <main>'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in require'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in block in require_with_bootsnap_lfi'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in register'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in require_with_bootsnap_lfi'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/bootsnap-1.3.1/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in require'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in block in require'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:249:in load_dependency'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/activesupport-5.2.0/lib/active_support/dependencies.rb:283:in require'
from /Users/maple002/Desktop/kaosaiyou/bin/rails:9:in <top (required)>'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in load'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in call'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/spring-2.0.2/lib/spring/client/command.rb:7:in call'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/spring-2.0.2/lib/spring/client.rb:30:in run'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/spring-2.0.2/bin/spring:49:in <top (required)>'
from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in load'     from /Users/maple002/Desktop/kaosaiyou/vendor/bundle/ruby/2.3.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in <top (required)>'
from /Users/maple002/.rbenv/versions/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:68:in require'     from /Users/maple002/.rbenv/versions/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:68:in require'
from /Users/maple002/Desktop/kaosaiyou/bin/spring:15:in <top (required)>'     from bin/rails:3:in load'
from bin/rails:3:in `<main>'

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

https://qiita.com/renny1398/items/5df494a2b2f5d74b24f4

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.51%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    http://localhost:3000/ が開けません。

    前提・実現したいこと Ruby on rails を用いて新しくアプリを作成するため、 「http://localhost:3000/」 を開こうとしたところ、 下記のエラー

  • 受付中

    Ruby 2.3.0 gem pg version 0.18.4 install エラー

    Errno::EACCES: Permission denied @ rb_sysopen - /Users/daisukeishii/tasca-io/vendor/bundle

  • 解決済

    railsのgemで導入したJQueryプラグインファイルについて

    いつも皆さんにはお世話になっています。 この度、gemでFullcalendarというJQueryで作成しているカレンダーを導入したのですが、少しカスタマイズを加えたいと思い

  • 受付中

    rails server コマンドでエラーがでます(cannnot load such file)

    railsでアプリを作ろうとしています。 rails new で新しいフォルダを作成まではできるのですが、そのディレクトリに移動してrails -vや、 rails -sコマンド

  • 解決済

    Railsのコントローラーのテストでのエラー

    Railsアプリケーションプログラミングを学習しながら作っていますが、コントローラーのテストを実行使用としたらエラーが出て解決出来ずに困っております。実行したコードは下記になります

  • 解決済

    bundle installができない エラー

    昨日、nokogiriのインストールでエラーが出るという質問を投稿させていただきました。 nokogiriのせいなのかと思っていたのですが、そもそもrails sもできないという状

  • 受付中

    bundler -vの際のエラーについて

    お世話になっております。 Railsの開発環境を構築しているものです。 gem install bundlerでbundlerをインストール後 bundler -vでバージョン確認

  • 解決済

    Rails s エラーが出て困っています。

     前提・実現したいこと railsの動作確認を行おうとしています。 $rails s を実行しようとすると下記の様に表示されて困っています。 どなたか教えて頂けませんでしょうか

同じタグがついた質問を見る

  • Ruby on Rails

    7298questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。