質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • FFmpeg

    87questions

    FFmpegは、動画と音声を交換できるフリーソフトウェアです。UNIX系OSから派生した、MS-DOSから操作するコマンドラインツールです。libavcodecやlibavformat、libswscale、libavfilterなどを含みます。ライセンスは、コンパイルの際のオプションによりLGPLもしくはGPLに決定されます。対応コーデックや使用できるオプションが多く、幅広く利用されています。

ffmpeg make 失敗する

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 332

aizawal-hiroki

score 35

ffmpegをawsのlinux環境に入れようとしているのですがmakeで失敗してしまいます

事前に関連パッケージ fdk-aac / last_x264 / yasm の3っつを入れています

ffmpegを.configurしたら

WARNING: using libfdk without pkg-config

WARNING: using libx264 without pkg-config


といった警告が出てきてダメだかなとおもいつつmakeをしたら

libavcodec/libx264.c: In function ‘X264_frame’:
libavcodec/libx264.c:271:9: error: ‘x264_bit_depth’ undeclared (first use in this function)
     if (x264_bit_depth > 8)
         ^
libavcodec/libx264.c:271:9: note: each undeclared identifier is reported only once for each function it appears in
libavcodec/libx264.c: In function ‘X264_init_static’:
libavcodec/libx264.c:898:9: error: ‘x264_bit_depth’ undeclared (first use in this function)
     if (x264_bit_depth == 8)
         ^
make: *** [libavcodec/libx264.o] Error 1

このようなエラーが発生しました。
error: ‘x264_bit_depth’ undeclared (first use in this function)
というエラーが発生しているのでlast_x264のコンパイル、ビルドがうまく行っていないと思いmake uninstallで一回削除し、もう一度makeし直してffmpegのmakeをしたところ同じエラーでした。

ご教授よろしくお願いします

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

私も同じエラーが発生していましたが、
PKG_CONFIG_PATHのパスを通すことで解決できました。

[root@tt]# export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig

[root@tt]# ls /usr/local/lib/pkgconfig/
fdk-aac.pc     libavdevice.pc  libavformat.pc  libpostproc.pc    libswscale.pc
libavcodec.pc  libavfilter.pc  libavutil.pc    libswresample.pc  x264.pc

同じ現象であれば、これで解決できるかと。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

  • 解決済

    ffmpegのアップデートをしたい

    環境/CentOS6.7を使用。 現在のffmpegのバージョンが下記です。 見ていると、2.8や3.0のバージョンがあるようなのですが、下記の「version N-790

  • 解決済

    CentOS7でffmpegのインストールができない

    前提・実現したいこと CentOS7でffmpegをインストールしたいのですが、 makeの途中でエラーが出て、インストール出来ません。 エラーメッセージ libavc

  • 解決済

    FFmpegでのcudaを利用した変換のトラブル

    前提・実現したいこと 「デバイスがない」というようなエラーのようですが、ドライバーなどはインストールしておりまして、悩んでおります。 お知恵をお借りできればと思います。

  • 解決済

    FFMPEGのAndroidでの利用方法について

    Android 5.0以上を対象に動画編集アプリを開発しようとしていまして、そのために以下の環境にてAndroidへのFFMPEG組み込みを行おうとしております。 ・Android

  • 解決済

    UbuntuでDockerを使ったWordPress環境を作りたい

    デスクトップUbuntuでWordPressの開発環境を作ろうと思っています。 見様見真似でDockerを使ってみようと思ったのですが curl: (7) Failed to

  • 解決済

    milkcocoaをインストールできない

    ラズベリーパイ3を用いて、milkcocoaを利用しようと考えています。 しかし、npm install milkcocoaと入力すると以下のようなエラーが出ます。 pi@

  • 受付中

    ポインタのアドレスが変わってしまう

    始めまして、お世話になります。 C言語を用いて有限要素解析プログラムを作成しているときのエラーについて質問させてください。 動的に確保した配列に複数回アクセスし、都度計算を

  • 受付中

    OpenVPNでLAN間接続がうまくいかない。

     前提・実現したいこと Raspberry Pi3 Model B同士でOpenVPNを用いたLAN間接続。  トポロジ図(抜粋) 接続構成としては、Site AにあるR

同じタグがついた質問を見る

  • FFmpeg

    87questions

    FFmpegは、動画と音声を交換できるフリーソフトウェアです。UNIX系OSから派生した、MS-DOSから操作するコマンドラインツールです。libavcodecやlibavformat、libswscale、libavfilterなどを含みます。ライセンスは、コンパイルの際のオプションによりLGPLもしくはGPLに決定されます。対応コーデックや使用できるオプションが多く、幅広く利用されています。