質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.53%

  • Python

    7884questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Apache

    1810questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

apache上でpyenvバージョンのpythonの呼び出しをしたいです.

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 143

 前提・実現したいこと

apache上でpyenvのpythonの呼び出しをしたいです.
pyenvのpythonの実行ファイルのpathを指定したときに,以下のエラーメッセージが発生しました。

 発生している問題・エラーメッセージ

[Tue Jul 10 09:24:32.665701 2018] [cgi:error] [pid 4618] [client ::1:61889] AH01215: (8)Exec format error: exec of '/Library/WebServer/CGI-Executables/pyworks/form_expla.py' failed: /Library/WebServer/CGI-Executables/pyworks/form_expla.py
[Tue Jul 10 09:24:32.665872 2018] [cgi:error] [pid 4618] [client ::1:61889] End of script output before headers: form_expla.py

 該当のソースコード

#!/Users/myname/.pyenv/shims/python
import cgi
import sys

print("Content-Type: text/html\n")

print("<html>Hello World<body>")
print("%s " % "<br>"+sys.version+"<br>")

 試したこと

myPCname:CGI-Executables myname$ which python
/Users/myname/.pyenv/shims/python
から/usr/bin/env pythonに変更.

#!/usr/bin/env python
import cgi
import sys

print("Content-Type: text/html\n")

print("<html>Hello World<body>")
print("%s " % "<br>"+sys.version+"<br>")

するとエラーは消えてhttp://localhost/cgi-bin/pyworks/form_expla.py
からアクセス可能となる.
ブラウザ上での出力結果は以下である.

Hello World 
2.7.10 (default, Oct 6 2017, 22:29:07) [GCC 4.2.1 Compatible Apple LLVM 9.0.0 (clang-900.0.31)]

しかし,デフォルトのpythonではなく, pyenv-virtualenvで実行するpythonのバージョンと,その時のパッケージが入っている環境で実行したい.

-なぜ,which python で出てくるpythonのパスでは, Apache上でエラーが出て,呼び出せないかがわかりません.

分かる方いたら,ぜひともなにかご教授頂けると幸いです.

 補足情報(FW/ツールのバージョンなど)

myPCname:CGI-Executables myname$ python -V
Python 3.6.1
myPCname:CGI-Executables myname$ pyenv version
3.6.1 (set by /Users/myname/.pyenv/version)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+3

最近全く同じ現象の質問に回答しました。
LinuxじゃなくてMacOSとかですよね?
Linuxじゃないと#!の後にシェルスクリプトは指定できません。


#!/usr/bin/env /Users/myname/.pyenv/shims/python

/usr/bin/envを思いついたのは良いのに、なぜpythonをフルパスで書かない?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/07/10 15:33 編集

    回答ありがとうございます.
    MacOSです.
    おっしゃる通りに,
    #!/usr/bin/env /Users/myname/.pyenv/shims/python
    に変更することでpyenvによるpythonのバージョンを指定して実行できました.
    また,下記の
    #!/Users/myname/.pyenv/versions/3.6.1/bin/python
    に変えても実行できました.

    とりあえず,pyenvのバージョンを指定して,pythonを実行することができました.
    しかし,まだ,virtualenvの環境内にpipでインストールされているpythonモジュールを反映することができていません.


    /usr/bin/envを思いついたのは良いのに、なぜpythonをフルパスで書かない?
    >>フルパスで書かないと駄目なのですね.知りませんでした.他のサイトを見ていたときに,pythonだけ記述されていたので,真似して書いていました.ご教授いただきありがとうございます.

    キャンセル

  • 2018/07/10 15:50

    > virtualenvの環境内にpipでインストールされているpythonモジュールを

    環境変数が適切に設定されていないのでは?

    > 他のサイトを見ていたときに,pythonだけ

    それは、環境変数PATHで最初に見つかるpythonを実行しろという意味です。

    キャンセル

  • 2018/07/10 16:21

    コメントありがとうございます.
    > 環境変数が適切に設定されていないのでは?
    おそらくその通りだとは思っております.しかし,pyenvの仕組みがあまりわかっていないまま使っており,どの設定ファイルの中身をいじればよいのかが,わからずにいるというのが現状です.

    > それは、環境変数PATHで最初に見つかるpythonを実行しろという意味です。
    そうなんですね.分かりました.ありがとうございます.

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.53%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python

    7884questions

    Pythonは、コードの読みやすさが特徴的なプログラミング言語の1つです。 強い型付け、動的型付けに対応しており、後方互換性がないバージョン2系とバージョン3系が使用されています。 商用製品の開発にも無料で使用でき、OSだけでなく仮想環境にも対応。Unicodeによる文字列操作をサポートしているため、日本語処理も標準で可能です。

  • Apache

    1810questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。