質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.50%

  • Ubuntu

    1407questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • VirtualBox

    762questions

    VirtualBoxは、現在米オラクル社が開発している、 x86仮想化ソフトウェア・パッケージの一つです。

ubuntuでbake.py showでのエラー

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 283

programan

score 3

 ubuntuにpython-pygoocanvasとpython-setuptoolsをインストールしたい

MacにVirtualbox(5.2.12)をいれ、そこにubuntu(18.04)をインストールしました。ns-3.28を使ってみようと思い、以下のサイトを参考に
https://qiita.com/haltaro/items/b474d924f63692c155c8
環境構築しています。必要なパッケージをインストールして、bake.py showをした結果以下のようなエラーメッセージ表示されたため指示通りにインストールしようとしましたがうまくできませんでした。
初めてubuntuを使うのでわからないことだらけです。ご教授願います。

bake.py show

-- System Dependencies --
 > clang-dev - OK
 > g++ - OK
 > libxml2-dev - OK
 > pygoocanvas - Missing
   >> The pygoocanvas is not installed, try to install it.
   >> Try: "sudo apt-get install python-pygoocanvas", if you have sudo rights.
 > pygraphviz - OK
 > python-dev - OK
 > qt - OK
 > setuptools - Missing
   >> The python-setuptools package is not installed, try to install it.
   >> Try: "sudo apt-get install python-setuptools", if you have sudo rights.

 sudo apt-get install python-pygoocanvas

パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
E: パッケージ python-pygoocanvas が見つかりません

 sudo apt-get install python-setuptools

パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
python-setuptools はすでに最新バージョン (39.0.1-2) です。
アップグレード: 0 個、新規インストール: 0 個、削除: 0 個、保留: 8 個。


sudo apt-get install python-setuptoolsは、インストールできているのですが、なぜかbake.py showコマンドを打つとMissingと表示されてしまいます。

 補足情報(FW/ツールのバージョンなど)

Virtualbox(5.2.12)
ubuntu(18.04)
mac OS High Sierra(10.13.2)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

Ubuntu18.04ではなくて、16.04で入れるとうまくいくような気がします。

 理由

  • Ubuntuは、バージョンが変わるとパッケージ名が変わるケースがある。
  • Qiitaの記事は、Ubuntu14.04でやったと書いてあり、Ubuntu18.04ではない。
  • ns-3のインストール手順を見て見ると、Ubuntu16.04の手順は書いてあるけど、Ubuntu 18.04は書いてない。(Ubuntu18.04は、2018年5月にリリースされたばかりです)

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/08/10 02:26

    Ubuntu16.04で試した結果サンプルコードまでうまく動かすことができました。
    回答ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ubuntu

    1407questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • VirtualBox

    762questions

    VirtualBoxは、現在米オラクル社が開発している、 x86仮想化ソフトウェア・パッケージの一つです。