質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.83%

  • Drupal

    18questions

    DrupalはPHPで書かれたオープンソースのCMSフレームワークです。

Drupal のwebformモジュール

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 53

R2D7

score 4

Drupal で拡張機能を利用してwebformモジュールを
インストールしました。

ただし、下記のようなエラーで有効に設定ができません。

尚、現在のDrupalCore のバージョンは8.2.4なのですが、
8.3以上へバージョンアップをしなさいという意味でしょうか?

Enables the creation of webforms and questionnaires.
マシン名: webform
バージョン: 8.x-5.0-rc15
FieldSystem (>= 8.3) (version 8.2.4 に不適合 )User が必要
Webform Bootstrap (無効)Webform Node (無効)Webform Demo: Application/Evaluation System (無効)Webform Scheduled Email Handler (無効)Webform Demo: Event Registration System (無効)Webform Devel (無効)Webform Example Composite (無効)Webform Element Example (無効)Webform Remote Post Example (無効)Webform Examples (無効)Webform Image Select (無効)Webform Templates (無効)Webform UI (無効) に必要
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+2

エラーメッセージの意味としてはご認識の通りです。

別の観点になりますが、
Drupalの現行メジャーバージョンについては最新のマイナーバージョンのStable版以外はサポート対象外なので8.4までののバージョンはクローズドな環境以外はでは使うべきではありません。
参考

つい先日に極めて致命的な脆弱性が公開されており、公式には8.4.7以上もしくは8.5.2以上のアップデートによる解消が推奨されています。
参照1(このページ内のリンク先の方が大本)
IPAによる日本語解説
(この件で8.4系がサポートされたのは8.5正式リリース直後というタイミングであることと、脆弱性の影響が大きすぎるという理由を鑑みてサポート対象とされた様です)

そのため、最低でも8.4系最新、可能な限り8.5系最新にアップデートされることをお勧めします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+2

はい、そういう意味になります。ただしバージョンアップする場合、8.5.2以前は脆弱性があるかサポート切れの可能性が高いのでご注意ください。8.5.3以降へバージョンアップすることをおすすめします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.83%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Drupal

    18questions

    DrupalはPHPで書かれたオープンソースのCMSフレームワークです。