質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.61%

  • SSL

    495questions

    SSL(Secure Sockets Layer)とは、暗号化されたプロトコルで、インターネット上での通信セキュリティを提供しています。

mod_sslがインストールできません

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 200

salamoni

score 1

Centos6.5 apache2.2.26 を使用しているWebサーバでmod_sslを
インストールしようとしているのですが、うまくいかず困っておりまして
初めて投稿させて頂きました。

yum -y install httpd mod_ssl を実行した所

Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Determining fastest mirrors
Could not retrieve mirrorlist http://apt.sw.be/redhat/el6/en/mirrors-rpmforge error was
14: PYCURL ERROR 6 - "Couldn't resolve host 'apt.sw.be'"

  • base: ftp.iij.ad.jp
  • extras: ftp.iij.ad.jp
  • remi: ftp.riken.jp
  • remi-php56: ftp.riken.jp
  • remi-safe: ftp.riken.jp
  • rpmforge: ftp.riken.jp
  • updates: ftp.iij.ad.jp


    87 packages excluded due to repository priority protections
    Setting up Install Process
    Package matching httpd-2.2.15-60.el6.centos.6.x86_64 already installed. Checking for update.
    Resolving Dependencies
    --> Running transaction check
    ---> Package mod_ssl.x86_64 1:2.2.15-60.el6.centos.6 will be installed
    --> Processing Dependency: httpd = 2.2.15-60.el6.centos.6 for package: 1:mod_ssl-2.2.15-60.el6.centos.6.x 86_64
    --> Finished Dependency Resolution
    Error: Package: 1:mod_ssl-2.2.15-60.el6.centos.6.x86_64 (updates)
    Requires: httpd = 2.2.15-60.el6.centos.6
    Installed: httpd-2.2.26-2.el6.x86_64 (@CentALT)
    httpd = 2.2.26-2.el6
    Available: httpd-2.2.15-59.el6.centos.x86_64 (base)
    httpd = 2.2.15-59.el6.centos
    Available: httpd-2.2.15-60.el6.centos.4.x86_64 (updates)
    httpd = 2.2.15-60.el6.centos.4
    Available: httpd-2.2.15-60.el6.centos.5.x86_64 (updates)
    httpd = 2.2.15-60.el6.centos.5
    Available: httpd-2.2.15-60.el6.centos.6.x86_64 (updates)
    httpd = 2.2.15-60.el6.centos.6
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

とエラーになってしまい。# rpm -qa | egrep "httpd|mod_ssl" で確認すると

httpd-2.2.26-2.el6.x86_64
httpd-devel-2.2.26-2.el6.x86_64
httpd-tools-2.2.26-2.el6.x86_64

やはり、mod_sslがインストールできませんでした。 エラーにある、--skip-broken を入れて再度試すと

yum -y --skip-broken install mod_ssl
Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile

  • base: ftp.iij.ad.jp
  • extras: ftp.iij.ad.jp
  • remi: ftp.riken.jp
  • remi-php56: ftp.riken.jp
  • remi-safe: ftp.riken.jp
  • rpmforge: ftp.riken.jp
  • updates: ftp.iij.ad.jp
    87 packages excluded due to repository priority protections
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package mod_ssl.x86_64 1:2.2.15-60.el6.centos.6 will be installed
    --> Processing Dependency: httpd = 2.2.15-60.el6.centos.6 for package: 1:mod_ssl-2.2.15-60.el6.centos.6.x86_64

Packages skipped because of dependency problems:
1:mod_ssl-2.2.15-60.el6.centos.6.x86_64 from updates

となりました。
依存関係が問題のようなのですが、どうすればよいかわかりません。

何か解決方法があればと、投稿させて頂きました。
どなたかご教授をお願いできないでしょうか。

よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

意図的に、@CentALT リポジトリから、標準と異なるバージョンのhttpdを入れたようですが、忘れてしまったんでしょうか?mod_sslも同じ手順で入れられるかと思います。
やったことは憶えておくか、記録するかしましょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/06/20 13:27

    otn様
    早速のご回答ありがとうございました。
    大変お恥ずかしい話ですが、当時設定した者がおらず、記録が残っておりません。

    なにか解決策はありますでしょうか。よろしくお願いいたします。

    キャンセル

  • 2018/06/20 14:09

    おそらく --enablerepo=CentALT
    エラーの場合は、/etc/yum.repos.d/ の下を見て探してください。

    設定が闇の中のサーバーの管理ですか。大変ですね。
    そうすると、何故異なるバージョンを入れたのかの理由も不明ですか?

    キャンセル

  • 2018/06/20 15:36

    otn 様
    回答ありがとうございます。

    頂いた内容で試してみましたが
    #yum -y --enablerepo=CentALT install mod_ssl

    同じようなエラーでして、 /etc/yum.repos.d/ を見てみたのですが
    mod_sslに関するエラーはありませんでした。

    Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
    Loading mirror speeds from cached hostfile
    * base: ftp.iij.ad.jp
    * extras: ftp.iij.ad.jp
    * remi: ftp.riken.jp
    * remi-php56: ftp.riken.jp
    * remi-safe: ftp.riken.jp
    * rpmforge: ftp.riken.jp
    * updates: ftp.iij.ad.jp
    http://centos.alt.ru/repository/centos/6/x86_64/repodata/repomd.xml: [Errno 14] Peer cert cannot be verified or peer cert invalid
    Trying other mirror.
    168 packages excluded due to repository priority protections
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package mod_ssl.x86_64 1:2.2.15-60.el6.centos.6 will be installed
    --> Processing Dependency: httpd = 2.2.15-60.el6.centos.6 for package: 1:mod_ssl-2.2.15-60.el6.centos.6.x86_64
    --> Finished Dependency Resolution
    Error: Package: 1:mod_ssl-2.2.15-60.el6.centos.6.x86_64 (updates)
    Requires: httpd = 2.2.15-60.el6.centos.6
    Installed: httpd-2.2.26-2.el6.x86_64 (@CentALT)
    httpd = 2.2.26-2.el6
    Available: httpd-2.2.15-59.el6.centos.x86_64 (base)
    httpd = 2.2.15-59.el6.centos
    Available: httpd-2.2.15-60.el6.centos.4.x86_64 (updates)
    httpd = 2.2.15-60.el6.centos.4
    Available: httpd-2.2.15-60.el6.centos.5.x86_64 (updates)
    httpd = 2.2.15-60.el6.centos.5
    Available: httpd-2.2.15-60.el6.centos.6.x86_64 (updates)
    httpd = 2.2.15-60.el6.centos.6
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    全くの闇の中でして、この辺のドキュメントがなく
    何故異なるバージョンを入れたのか不明なんです・・。

    キャンセル

  • 2018/06/20 15:40

    > 同じようなエラーでして、 /etc/yum.repos.d/ を見てみたのですが
    > mod_sslに関するエラーはありませんでした。

    /etcの下なので、ログじゃないです。設定ファイルです。CentALTに関係してそうなファイルはないですか?
    無ければ消されたんでしょうね。CentALTからのインストール方法を調べてください。/etc/yum.repos.dの下にファイルを置いてそれをenableにしてインストールします。

    キャンセル

  • 2018/06/20 17:22

    otn様 色々と助言ありがとうございます。

    CentALTに関係してそうなファイルありました。 そこに
    [CentALT]
    name=CentALT Packages for Enterprise Linux 6 - $basearch
    baseurl=http://centos.alt.ru/repository/centos/6/$basearch/
    enabled=0
    gpgcheck=0
    とありましたので、enabled=1 に修正し

    再度 #yum -y --enablerepo=CentALT install mod_ssl
    を試したのですが、エラーとしては変わりませんでした。

    yum -y --enablerepo=CentALT --skip-broken install mod_ssl
    Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
    Loading mirror speeds from cached hostfile
    * base: ftp.iij.ad.jp
    * extras: ftp.iij.ad.jp
    * remi: ftp.riken.jp
    * remi-php56: ftp.riken.jp
    * remi-safe: ftp.riken.jp
    * rpmforge: ftp.riken.jp
    * updates: ftp.iij.ad.jp
    http://centos.alt.ru/repository/centos/6/x86_64/repodata/repomd.xml: [Errno 14] Peer cert cannot be verified or peer cert invalid
    Trying other mirror.
    168 packages excluded due to repository priority protections
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package mod_ssl.x86_64 1:2.2.15-60.el6.centos.6 will be installed
    --> Processing Dependency: httpd = 2.2.15-60.el6.centos.6 for package: 1:mod_ssl-2.2.15-60.el6.centos.6.x86_64

    Packages skipped because of dependency problems:
    1:mod_ssl-2.2.15-60.el6.centos.6.x86_64 from updates

    キャンセル

  • 2018/06/20 20:28

    CentALTが認識されていませんね。
    http://centos.alt.ru/repository/centos/6/
    にアクセスしてみると、SSL証明書が不正ですが、それを無視しても404なので、もうサービスしていないのかも。
    CentALTで検索すると、いろいろ情報がありますね。

    バージョンを標準の物に下げる検討もした方が良いかもしれません。

    キャンセル

  • 2018/06/21 17:54

    otn 様

    色々と助言頂きありがとうございました。
    どういう方向で行くか、検討したいと思います。

    キャンセル

  • 2018/07/04 16:15

    otn 様
    先日は色々と助言頂きましてありがとうございました。
    とても勉強になりました。
    色々と検討した結果、別サーバをたて、移行する事にしました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • SSL

    495questions

    SSL(Secure Sockets Layer)とは、暗号化されたプロトコルで、インターネット上での通信セキュリティを提供しています。