質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.78%

CentOSのGMPをアップデート

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,330

score 16

CentOS6.6を使用しています
中身のアップデートということでGMPを確認したところgmp-4.3.1-7.el6-2.2.x86_64でした
GMP5.0.5以上が要求されるプログラムを使用したいのでアプデートしようと思うのですがyum remove gmpあたりで消そうとしてもエラーで消えません
ちょっと古い日付ですが要求スペックを満たしていたので以下のサイトを参考にしてインストールしようとしたのですがmakeの段階でエラーが出ます
全くどうしていいのかわかりません、よろしくお願いします
http://manshinsoui.blog.shinobi.jp/%E6%9C%AA%E9%81%B8%E6%8A%9E/centos%206.3%20%E3%81%A7%20gcc-4.7.1%E3%82%A4%E3%83%B3%E3%82%B9%E3%83%88%E3%83%BC%E3%83%AB%E3%81%97%E3%81%A6%E3%81%BF%E3%81%9F
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

GMPはGCC以外にも、言語処理系など多くのプログラムから使われているものですので、簡単に上書きしてしまうとトラブルの原因になります。

GMPのconfigure時点で--prefix=を入れて別なディレクトリに新しいGMPを入れて、GCCのconfigure時にそちらを参照させる、というような手段を取るのがいいのではないかと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/07/24 00:01

    純粋にアップデートするだけでも何か問題が生じる場合があるのでしょうか?
    イメージとしてバージョンが上なら下位バージョンの内容も含んでる感じなのですが
    とにかく--prefix=で試してみようと思います

    キャンセル

  • 2015/07/24 11:12

    単純にアップデートをする場合でも問題が起きることが多々あります。

    上位バージョンで下位バージョンの動作が変更されること等があるので、
    依存しているプログラムが想定通りの結果を得られずに異常をきたしてしまう
    といった例えだと想像してもらえるでしょうか。

    依存関係が多いパッケージのアップグレードは要注意です。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.78%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る