質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.74%

  • Ruby on Rails

    6723questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • RubyGems

    304questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

[Ruby on Rails]bundle install でのエラー解決方法

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 101

hahah

score 1

 bundle install でエラーが出たので、nio4rをインストールしようとしてエラー

実行環境はUbuntuです。
VPSでrailsサーバーを構築しようと思っています。
bundle install して、以下のエラーが出たため、

An error occurred while installing nio4r (2.3.1), and Bundler cannot continue.
Make sure that `gem install nio4r -v '2.3.1' --source 'https://rubygems.org/'` succeeds before
bundling.

In Gemfile:
  rails was resolved to 5.2.0, which depends on
    actioncable was resolved to 5.2.0, which depends on
      nio4r

sudo gem install nio4r -v '2.3.1'
を実行して、以下のエラーメッセージが発生しました。

Building native extensions. This could take a while...
ERROR:  Error installing nio4r:
        ERROR: Failed to build gem native extension.

    current directory: /var/lib/gems/2.5.0/gems/nio4r-2.3.1/ext/nio4r
/usr/bin/ruby2.5 -r ./siteconf20180612-30053-12taw3j.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.5.0/gems/nio4r-2.3.1 for inspection.
Results logged to /var/lib/gems/2.5.0/extensions/x86_64-linux/2.5.0/nio4r-2.3.1/gem_make.out

結果として、bundle install が上手くいけばいいのですが、bundle install を成功させるためには、
nio4rをインストールしないといけないと思うのですが、どうすればよいでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

rubyをなんらかのパッケージマネージャーでインストールしたのでしょうか
ruby.hが見つからないというのでruby-develruby-dev的なパッケージがあると思うので
それをインストール

よく分からなければrbenvおよびruby-buildからrubyをインストールし直せばいいと思います

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/06/13 01:50 編集

    sudo apt install ruby-dev を実行しました。エラーなし。
    私の見ていたポイントが違いました。
    can't find header files for ruby at /usr/lib/ruby/include/ruby.hを見て、
    ruby.hが見つからないというのでruby-develやruby-dev的なパッケージをインストールをする
    と考えるのですね。勉強になりました。
    目的のbundle install とbundle updete も成功しました。
    そのあと、uglifierが必要とかエラーが出て、インストール、Could not find a JavaScript runtime. とエラーが出て、https://qiita.com/htk_jp/items/1100a04f45151c928378 このサイトを参考にしたりして、rails serverのコマンドまで成功しました。
    asmさん、本当にありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.74%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby on Rails

    6723questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • RubyGems

    304questions

    RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。