質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.76%

  • Ruby

    7027questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 5

    1291questions

突如rails sができなくなった

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 136

Doppon

score 10

 背景

Rails5.2.0がリリースされたので切り替えたっきり、そのままにしておいたら
なぜかrailsコマンドの大半が使えなくなってしまってました。。。

 ruby/railsのバージョン

$ ruby -v
ruby 2.6.0dev (2018-02-24 trunk 62563) [x86_64-darwin16]
$ rails -v
Rails 5.2.0

 エラー内容

$ rails new huga
...(hugaアプリが作られる)
$ cd huga
$ ruby -v
rbenv: version `2.6.0' is not installed (set by /Users/hogeuser/huga/.ruby-version)
$ rails s
ruby 2.6.0dev (2018-02-24 trunk 62563) [x86_64-darwin16]

-- Crash Report log information --------------------------------------------
   See Crash Report log file under the one of following:                    
     * ~/Library/Logs/DiagnosticReports                                     
     * /Library/Logs/DiagnosticReports                                      
   for more details.                                                        
Don't forget to include the above Crash Report log file in bug reports.     

-- Control frame information -----------------------------------------------
.
.
.
[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

[IMPORTANT]
Don't forget to include the Crash Report log file under
DiagnosticReports directory in bug reports.

っといった具合です。

 試したこと

$ brew update
(略)

$ brew upgrade rbenv ruby-build
Error: rbenv 1.1.1 already installed
Error: ruby-build 20180601 already installed

$ rbenv install 2.6.0
ruby-build: definition not found: 2.6.0

See all available versions with `rbenv install --list'.

If the version you need is missing, try upgrading ruby-build:

  cd /Users/hogeuser/.rbenv/plugins/ruby-build && git pull && cd -

$ cd /Users/hogeuser/.rbenv/plugins/ruby-build && git pull
(ココで最新版に更新)

$ rbenv install -l
.
.
.
2.6.0-dev
2.6.0-preview1
2.6.0-preview2
.
.
.

$ rbenv install 2.6.0-dev
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

$ ruby -v
rbenv: version `2.6.0' is not installed (set by /Users/hogeuser/huga/.ruby-version)

上記から、hugaディレクトリでrbenv localコマンドの指定を間違えていることが伺えます。
2.6.0はまだリリースされていませんね。
2.6.0-devと指定すべきです。

一方で、railsアプリを開発版バージョンのRubyで動かすの?という懸念があります。
2.6ではJITコンパイラが取りこまれたりと、結構劇的に変わっています。
不都合がなければ、正式版の2.5系で動かすのが賢明かと思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/06/05 01:10 編集

    kaztoさん

    ご教示ありがとうございます!!!

    2.5.0の安定板に落としたところ、問題なくRailsが動くようになりました!
    本当に助かりました。ありがとうございます。

    それはそれと、JITコンパイラが組み込まれたりしてJavaや他の言語に劣らないとまるで自負できると喜んでいた自分がその意味を考えきれていなかった事に恥ずかしい限りです。。

    ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.76%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7027questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails 5

    1291questions