質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.52%

  • Ubuntu

    1398questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • apt-get

    40questions

    apt-getコマンドはUNIX系OSのパッケージのインストールなど、パッケージ管理を行うためのコマンドです。

ubuntu16.04で依存関係が壊れてapt-get install ができない

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 2
  • VIEW 1,069

hukuhuku

score 2

 前提・実現したいこと

以前はできたのですが,
Ubuntu 16.04でapt-get install によりパッケージをインストールしたいのですがうまくできません。

 発生している問題・エラーメッセージ

hogehoge@hoge-jjjjj:~$ sudo apt-get -f install vim
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
以下の問題を解決するために 'apt-get -f install' を実行する必要があるかもしれません:
以下のパッケージには満たせない依存関係があります:
 libpam-modules : 先行依存: libpam-modules-bin (= 1.1.8-3.2ubuntu2)
                  推奨: update-motd しかし、インストールされようとしていません
 vim : 依存: vim-runtime (= 2:7.4.1689-3ubuntu1.2) しかし、インストールされようとしていません
E: 未解決の依存関係です。'apt-get -f install' を実行してみてください (または解法を明示してください)。

 試したこと

sudo apt-get update は実行できたのですがその後の sudo apt-get upgrade ができませんでした
上と同じようなエラーが出ます。

sudo apt clean ;sudo apt autoremoveを試しましたができませんでした

/etc/apt/sources.listを以前付け加えたことがあったのでそれも削除しました。
下が現在のsources.listです

#deb cdrom:[Ubuntu 15.04.2 LTS _Xenial Xerus_ - Release amd64 (20170215.2)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://jp.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://jp.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://jp.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://jp.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://jp.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://jp.archive.ubuntu.com/ubuntu/ xenial universe
deb http://jp.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://jp.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to

## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://jp.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://jp.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://jp.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://jp.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://jp.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://jp.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

sudo apt-get remove --purge libpam-modulesを試してみましたが

libpam-modules
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
以下の問題を解決するために 'apt-get -f install' を実行する必要があるかもしれません:
以下のパッケージには満たせない依存関係があります:
 libpam-runtime : 依存: libpam-modules (>= 1.0.1-6) しかし、インストールされようとしていません
 lightdm : 依存: libpam-modules しかし、インストールされようとしていません
 login : 先行依存: libpam-modules (>= 1.1.8-1) しかし、インストールされようとしていません
 passwd : 依存: libpam-modules しかし、インストールされようとしていません
 ppp : 依存: libpam-modules しかし、インストールされようとしていません
 sudo : 依存: libpam-modules しかし、インストールされようとしていません
E: 未解決の依存関係です。'apt-get -f install' を実行してみてください (または解法を明示してください)。

このようにエラーが出ます。

また,sudo dpkg --audit を実行すると

ケージはインストール中に重大な問題が発生したため混乱しています。
これらのパッケージ (とこれらに依存するパッケージ) が正しく動作するために
は、以下のパッケージを再インストールしなければなりません:
 linux-image-4.10.0-27-generic (説明 (description) がありません)

以下のパッケージは展開されましたが、まだ設定されていません。
これらのパッケージが正常に動作するためには、dpkg --configure か
dselect の設定 (configure) メニューオプションを使って設定を完了
させなければなりません:
 linux-image-extra-4.10.0-27-generic Linux kernel extra modules for version 4.1
 linux-image-generic-hwe-16.04 Generic Linux kernel image
 linux-signed-image-4.10.0-27-generic Signed kernel image generic
 linux-signed-image-generic-hwe-16.04 Signed Generic Linux kernel image

以下のパッケージは最初の設定中に問題が発生したため、設定が終了していません。
dpkg --configure <パッケージ> か dselect で設定 (configure) メニューオプショ
ンを使って設定作業を再試行しなければなりません:
 libpam-systemd:amd64 system and service manager - PAM module

以下のパッケージは、データベース中に list 制御ファイルが見つかりません。
再インストールする必要があります:
 linux-image-4.10.0-27-generic (説明 (description) がありません)

以下のパッケージは、データベース中に md5sums 制御ファイルが見つかりません。
再インストールする必要があります:
 linux-image-4.10.0-27-generic (説明 (description) がありません)


と出るのでこちらを再インストールする必要があるのでしょうか?

とのようにエラーが出ます

 補足情報(FW/ツールのバージョンなど)

バージョンは16.04.2 LTS (Xenial Xerus)です

よろしくお願いします

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • keicha_hrs

    2018/05/11 14:25

    その状況で動作しているカーネルのバージョンは何なのでしょうか?uname -rの結果も補足された方がいいでしょう。

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.52%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ubuntu

    1398questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

  • apt-get

    40questions

    apt-getコマンドはUNIX系OSのパッケージのインストールなど、パッケージ管理を行うためのコマンドです。