質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.36%

  • Ruby

    8149questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7642questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    2132questions

No such file or directory @ unlink_internalの解決方法

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 645

akaikesan

score 8

 前提・実現したいこと

ruby on rails で共同開発したいです

 発生している問題・エラーメッセージ

localhost:3000で開いてもNo such file or directory @ unlink_internal となって開けません。

 該当のソースコード

ruby

 

 補足情報(FW/ツールのバージョンなど)

windows10です 初心者です

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • akaikesan

    2018/05/04 18:07

    C:\jack\jhack> C:\jack\jhack>rails about C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/lib/bootstrap-sass/version.rb:2: warning: already initialized constant Bootstrap::VERSION C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-4.0.0/lib/bootstrap/version.rb:2: warning: previous definition of VERSION was here C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/lib/bootstrap-sass/version.rb:3: warning: already initialized constant Bootstrap::BOOTSTRAP_SHA C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-4.0.0/lib/bootstrap/version.rb:3: warning: previous definition of BOOTSTRAP_SHA was here Please add the following to your Gemfile to avoid polling for changes: gem 'wdm', '>= 0.1.0' if Gem.win_platform? Please add the following to your Gemfile to avoid polling for changes: gem 'wdm', '>= 0.1.0' if Gem.win_platform? About your application's environment Rails version 5.2.0 Ruby version 2.4.4-p296 (x64-mingw32) RubyGems version 2.6.14.1 Rack version 2.0.5 JavaScript Runtime JScript Middleware Rack::Sendfile, ActionDispatch::Static, ActionDispatch::Executor, ActiveSupport::Cache::Strategy::LocalCache::Middleware, Rack::Runtime, Rack::MethodOverride, ActionDispatch::RequestId, ActionDispatch::RemoteIp, Sprockets::Rails::QuietAssets, Rails::Rack::Logger, ActionDispatch::ShowExceptions, WebConsole::Middleware, ActionDispatch::DebugExceptions, ActionDispatch::Reloader, ActionDispatch::Callbacks, ActiveRecord::Migration::CheckPending, ActionDispatch::Cookies, ActionDispatch::Session::CookieStore, ActionDispatch::Flash, ActionDispatch::ContentSecurityPolicy::Middleware, Rack::Head, Rack::ConditionalGet, Rack::ETag, Rack::TempfileReaper Application root C:/jack/jhack Environment development Database adapter sqlite3 Database schema version 20180504005208

    キャンセル

  • akaikesan

    2018/05/04 18:09

    わざわざありがとうございます

    キャンセル

  • asm

    2018/05/04 18:19

    ありがとうございます

    キャンセル

回答 2

checkベストアンサー

+1

ファイルかディレクトリが無い、というエラーなので、
そのファイルかディレクトリがあるところを指定するようにコードを修正するか、
そのファイルかディレクトリを作るか移動させてくればいいです

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/04 16:52

    No such file or directory @ unlink_internal - C:/Users/ (僕の名前がここにありました)~1/AppData/Local/Temp/execjs20180504-7060-1tk1ut7jsonとなっているのですが、これでどのファイルとディレクトリが無いとわかりますか?

    キャンセル

  • 2018/05/04 16:54

    そこに書いてあるファイルかディレクトリではないでしょうか

    キャンセル

  • 2018/05/04 17:20

    無いはずなのに同じファイルがあるとなってしまい、ファイルが作れません。
    どうすればよいかわかりますでしょうか?

    キャンセル

  • 2018/05/04 17:23

    そもそもなにをどうしたいのか、そのエラーがどういうコードから出たのかわからないので、アドバイスのしようがないです

    キャンセル

  • 2018/05/06 14:57

    そもそもそのエラーが出たというソースを晒してもらわないと解決のしようがないとおもいますが。
    オイラはエスパーじゃないんだから

    キャンセル

  • 2018/05/06 15:55

    C:\jack\jhack>rails s
    C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/lib/bootstrap-sass/version.rb:2: warning: already initialized constant Bootstrap::VERSION
    C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-4.0.0/lib/bootstrap/version.rb:2: warning: previous definition of VERSION was here
    C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/lib/bootstrap-sass/version.rb:3: warning: already initialized constant Bootstrap::BOOTSTRAP_SHA
    C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-4.0.0/lib/bootstrap/version.rb:3: warning: previous definition of BOOTSTRAP_SHA was here
    => Booting Puma
    => Rails 5.2.0 application starting in development
    => Run `rails server -h` for more startup options
    Please add the following to your Gemfile to avoid polling for changes:
    gem 'wdm', '>= 0.1.0' if Gem.win_platform?
    Please add the following to your Gemfile to avoid polling for changes:
    gem 'wdm', '>= 0.1.0' if Gem.win_platform?
    *** SIGUSR2 not implemented, signal based restart unavailable!
    *** SIGUSR1 not implemented, signal based restart unavailable!
    *** SIGHUP not implemented, signal based logs reopening unavailable!
    Puma starting in single mode...
    * Version 3.11.4 (ruby 2.4.4-p296), codename: Love Song
    * Min threads: 5, max threads: 5
    * Environment: development
    * Listening on tcp://0.0.0.0:3000
    Use Ctrl-C to stop
    これですか?なかなか質問の仕方がわからなくて、、、

    キャンセル

  • 2018/05/06 16:08

    > * Version 3.11.4 (ruby 2.4.4-p296), codename: Love Song
    > * Min threads: 5, max threads: 5
    > * Environment: development
    > * Listening on tcp://0.0.0.0:3000
    > Use Ctrl-C to stop

    なんか起動してるんじゃね?

    キャンセル

  • 2018/05/06 16:11

    ああ、それで開いてもダメってはなしか。
    そんならいっその事一切合財アンインストールして改めてインストールし直してみればどお?
    ネットで転がってる実施例のとおりにすれば少なくとも起動するまでは持っていけるんじゃ

    キャンセル

  • 2018/05/06 16:12

    先輩がすでに作業しているんですがそれとは関係ありますか?
    ぼくのpcではlocalhost3000で検索してもエラーになってしまうんです

    キャンセル

  • 2018/05/06 16:13 編集

    そうですね、、、、
    それが一番ですかね、、、

    キャンセル

  • 2018/05/06 16:17

    今の環境を残さなけりゃならない、ってことがないなら、悩んでる時間で環境構築できるんでは。

    キャンセル

  • 2018/05/06 16:25

    そうですね
    ありがとうございました!

    キャンセル

0

JavaScript Runtime JScriptなので、
Node.jsがインストールされていないか検出されていません。

Node.jsを(ADD TO PATHのチェックを外さずに)インストールし
コマンドプロンプトを再起動してください

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/05 17:18

    インストールしたんですが、、
    No such file or directory @ unlink_internalとなります

    キャンセル

  • 2018/05/06 12:51

    rails about で
    JavaScript Runtime Node.js (V8)
    になっていますか?

    キャンセル

  • 2018/05/06 12:55

    C:\jack\jhack>rails about
    C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/lib/bootstrap-sass/version.rb:2: warning: already initialized constant Bootstrap::VERSION
    C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-4.0.0/lib/bootstrap/version.rb:2: warning: previous definition of VERSION was here
    C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-sass-3.3.7/lib/bootstrap-sass/version.rb:3: warning: already initialized constant Bootstrap::BOOTSTRAP_SHA
    C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/bootstrap-4.0.0/lib/bootstrap/version.rb:3: warning: previous definition of BOOTSTRAP_SHA was here
    Please add the following to your Gemfile to avoid polling for changes:
    gem 'wdm', '>= 0.1.0' if Gem.win_platform?
    Please add the following to your Gemfile to avoid polling for changes:
    gem 'wdm', '>= 0.1.0' if Gem.win_platform?
    About your application's environment
    Rails version 5.2.0
    Ruby version 2.4.4-p296 (x64-mingw32)
    RubyGems version 2.6.14.1
    Rack version 2.0.5
    JavaScript Runtime Node.js (V8)
    Middleware Rack::Sendfile, ActionDispatch::Static, ActionDispatch::Executor, ActiveSupport::Cache::Strategy::LocalCache::Middleware, Rack::Runtime, Rack::MethodOverride, ActionDispatch::RequestId, ActionDispatch::RemoteIp, Sprockets::Rails::QuietAssets, Rails::Rack::Logger, ActionDispatch::ShowExceptions, WebConsole::Middleware, ActionDispatch::DebugExceptions, ActionDispatch::Reloader, ActionDispatch::Callbacks, ActiveRecord::Migration::CheckPending, ActionDispatch::Cookies, ActionDispatch::Session::CookieStore, ActionDispatch::Flash, ActionDispatch::ContentSecurityPolicy::Middleware, Rack::Head, Rack::ConditionalGet, Rack::ETag, Rack::TempfileReaper
    Application root C:/jack/jhack
    Environment development
    Database adapter sqlite3
    Database schema version 20180504005208

    キャンセル

  • 2018/05/06 12:55

    なっています

    キャンセル

  • 2018/05/06 13:45

    うーん
    なってますねぇ なんだろ

    とりあえず、Bootstrapは2/3系と4系どちらかにしたほうがいいと思いますよ

    キャンセル

  • 2018/05/06 14:32

    boostrapのファイルをどちらか一方を消すということですね?

    キャンセル

  • 2018/05/06 15:14

    Gemfileを
    4系
    gem 'bootstrap', '~> 4.1.1'
    2/3系
    gem 'bootstrap-sass', '~> 3.3.7'
    gem 'sass-rails', '>= 3.2'
    を残す感じ

    gem "jquery-rails"
    も必要かも

    キャンセル

  • 2018/05/06 15:48

    すいません知識不足で何言ってるか分かりません(泣)
    Gemfileでは
    gem 'bootstrap', '~> 4.0.0.beta2.1'
    gem 'bootstrap-sass'
    gem 'sass-rails', '~> 5.0'
    というところがあったんですが、ここを書き換えるのですか?

    キャンセル

  • 2018/05/06 16:26

    失礼しました。gem 'sass-rails', '~> 5.0'は標準でありましたね。

    では,
    gem 'bootstrap', '~> 4.0.0.beta2.1'
    gem 'bootstrap-sass'
    は競合しそうなのでどちらか消して再度bundle installした方がよさそうです

    キャンセル

  • 2018/05/06 16:36

    消しました。他に何か効果のありそうなことありますか?
    これだけみてもらって申し訳ないですが、無かったのでしたら諦めてもういちど全部アンインストールしてからやり直そうと思います。

    キャンセル

  • 2018/05/06 16:48

    そうですか、お役に立てずすいません。

    rails new 直後は問題ないのか、Gemfileのみ書き換えて問題ないのか
    など一つずつ確認していくしかないでしょうね

    キャンセル

同じタグがついた質問を見る

  • Ruby

    8149questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    7642questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Ruby on Rails 5

    2132questions