質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.75%

  • Ruby

    7005questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6732questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

bundler -vの際のエラーについて

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 110

forbse

score 2

お世話になっております。
Railsの開発環境を構築しているものです。
gem install bundlerでbundlerをインストール後
bundler -vでバージョン確認した際に以下のエラーメッセージが発生しました。

エラーメッセージ

Traceback (most recent call last):
2: from /home/username/.rbenv/versions/2.5.0/bin/bundler:23:in `<main>'
1: from /home/username/.rbenv/versions/2.5.0/lib/ruby/site_ruby/2.5.0/rubybems.rb:308:in 'activate_bin_path'
/home/username/.rbenv/versions/2.5.0/lib/ruby/site_ruby/2.5.0/
rubygems.rb:289:in `find_spec_for_exe': can't find gem bundler (>= 0.a) 
with executable bundler (Gem::GemNotFoundException)


とエラーメッセージが発生しました。
解決方法のご教授よろしくお願いします。

*** LOCAL GEMS ***

actioncable (5.2.0)
actionmailer (5.2.0)
actionpack (5.2.0)
actionview (5.2.0)
activejob (5.2.0)
activemodel (5.2.0)
activerecord (5.2.0)
activestorage (5.2.0)
activesupport (5.2.0)
arel (9.0.0)
bigdecimal (default: 1.3.4)
builder (3.2.3)
bundler (default: 1.16.1)
cmath (default: 1.0.0)
concurrent-ruby (1.0.5)
crass (1.0.4)
csv (1.0.1, default: 1.0.0)
date (default: 1.0.0)
dbm (default: 1.0.0)
did_you_mean (1.2.1, 1.2.0)
erubi (1.7.1)
etc (default: 1.0.0)
fcntl (default: 1.0.0)
fiddle (default: 1.0.0)
fileutils (default: 1.0.2)
gdbm (default: 2.0.0)
globalid (0.4.1)
i18n (1.0.1)
io-console (default: 0.4.6)
ipaddr (default: 1.2.0)
json (default: 2.1.0)
loofah (2.2.2)
mail (2.7.0)
marcel (0.3.2)
method_source (0.9.0)
mimemagic (0.3.2)
mini_mime (1.0.0)
mini_portile2 (2.3.0)
minitest (5.11.3, 5.10.3)
net-telnet (0.1.1)
nio4r (2.3.0)
nokogiri (1.8.2)
openssl (default: 2.1.0)
power_assert (1.1.1)
psych (default: 3.0.2)
rack (2.0.5)
rack-test (1.0.0)
rails (5.2.0)
rails-dom-testing (2.0.3)
rails-html-sanitizer (1.0.4)
railties (5.2.0)
rake (12.3.1, 12.3.0)
rdoc (6.0.3, default: 6.0.1)
rubygems-update (2.7.6)
scanf (default: 1.0.0)
sdbm (default: 1.0.0)
sprockets (3.7.1)
sprockets-rails (3.2.1)
stringio (default: 0.0.1)
strscan (default: 1.0.0)
test-unit (3.2.7)
thor (0.20.0)
thread_safe (0.3.6)
tzinfo (1.2.5)
webrick (default: 1.4.2)
websocket-driver (0.7.0)
websocket-extensions (0.1.3)
xmlrpc (0.3.0)
zlib (default: 1.0.0)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • hichon

    2018/05/02 18:36

    gem listの結果を貼って下さい。

    キャンセル

  • forbse

    2018/05/02 19:54 編集

    gem listを追加しました。

    キャンセル

回答 1

0

以下のファイルをリネームしてみて下さい。

$ cd /home/username/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/specifications
$ mv bundler-1.16.1.gemspec bundler-1.16.1.gemspec_back

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/05/03 03:50

    ご回答の通りさせていただきましたが同様の結果でエラーが発生しました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.75%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Ruby

    7005questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    6732questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。