質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.83%

  • PHP

    18683questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • MacOS(OSX)

    1747questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

  • XAMPP

    453questions

    XAMPP(ザンプ)は、ウェブアプリケーションの実行に必要なフリーソフトウェアをパッケージングしたApacheディストリビューションです。 XAMPPひとつインストールするだけで、Apache、MySQL、PHP、Perlなどのソフトウェアと、 phpMyAdminなどの管理ツール、SQLiteなどのソフトウェアやライブラリモジュールなどを利用することが可能です。

XAMPPのPHPを使用したい|標準のphpとなんか混ざってる??

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 149

n_oshiumi

score 9

ターミナルで

which php
>/usr/bin/php


php --ini
>Configuration File (php.ini) Path: /etc
>Loaded Configuration File:         (none)
>Scan for additional .ini files in: (none)
>Additional .ini files parsed:      (none)

このように出ます。

でも、XAMPPのphp infoをみると

Configuration File (php.ini) Path ⇨ /Applications/XAMPP/xamppfiles/etc
Loaded Configuration File ⇨ //Applications/XAMPP/xamppfiles/etc/php.ini

と書いてあります。

Macの何かのPHP(標準のやつ???)とXAMPPのPHPが混同しているような気がします。

解決策を教えてください!!

【追記】apcu-bcインストール中でのエラー
・phpのバージョン7.1.14
・apcuのバージョン5.13
・apcu_bcのバージョン1.0.4
PHP Version: PHP 7.0.0 or newer
PEAR Package: PEAR 1.10 or newer
PECL Package: apcu 5.1.2 or newer

それぞれのバージョンはあっていると思うのですが、apcuが見つかりませんっていうエラーが出ます。

apcu-bcのインストール

cd /tmp
git clone https://github.com/krakjoe/apcu-bc
cd apcu-bc
phpize
./configure --enable-apc \
comporser install
make


エラーが出ます。
ちなみにXAMPPのphpinfo()にはapcuがエクステンションされているのが確認できます。

Your requirements could not be resolved to an installable set of packages.
  Problem 1
    - The requested PHP extension ext-apcu ~5.1 is missing from your system. Install or enable PHP's apcu extension.
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • n_oshiumi

    2018/04/27 11:00

    ご丁寧にありがとうございます!!

    キャンセル

  • kawakawa2018

    2018/04/27 11:30

    順に回答の補足をします。 まず解策ですがないです。といいますか問題なしですね。お使いのPCにはPHPは1つだけだと思います。  次に【追記】apcu-bcインストール中でのエラー は回答欄に追記しました。

    キャンセル

  • fiwa

    2018/04/27 22:55

    ふつうXAMPPで使用しているphpは、/Applications/XAMPP/xamppfiles/bin/php にあるものです。

    キャンセル

回答 1

checkベストアンサー

0

which php
>/usr/bin/php

ここで
/usr/bin/php -v
を実行するとバージョンはいくつが表示されますか?


【追記】apcu-bcインストール中でのエラー への回答

Install or enable PHP's apcu extension.

とでていますので php.iniファイルのapcu-bcの設定に誤りがあるのでは?

 解決策

  1. php.iniファイルを表示
  2. 設定内容を見て、#がついてコメント化されていれば#を外すなど設定を見直し/修正
  3. Apacheサーバを停止・再起動

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/04/27 11:14

    今見てみたのですが、そもそも「/usr/bin」の中に「php」がありませんでした。
    間違って消してしまったのでしょうか。。

    ちなみに、XAMPP入れる前に「php -v」で「7.1.14」が出てきたので、phpが同じバージョンになるようにXAMPPのインストールしました。

    キャンセル

  • 2018/04/27 11:15

    すみません、ありました!!!間違いでした!

    /usr/bin/php -v
    PHP 7.1.14 (cli) (built: Feb 7 2018 18:33:30) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.83%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • PHP

    18683questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • MacOS(OSX)

    1747questions

    MacOSとは、Appleの開発していたGUI(グラフィカルユーザーインターフェース)を採用したオペレーションシステム(OS)です。Macintoshと共に、市場に出てGUIの普及に大きく貢献しました。

  • XAMPP

    453questions

    XAMPP(ザンプ)は、ウェブアプリケーションの実行に必要なフリーソフトウェアをパッケージングしたApacheディストリビューションです。 XAMPPひとつインストールするだけで、Apache、MySQL、PHP、Perlなどのソフトウェアと、 phpMyAdminなどの管理ツール、SQLiteなどのソフトウェアやライブラリモジュールなどを利用することが可能です。