質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.75%

  • Python 3.x

    5308questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

linux opencvをpython3.5.2で利用したい

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 154

Sample_Test

score 123

私は、linux mint18,3 mate 64bit[16.04.1-Ubuntu]にpython3.6を新たにインストールしました。
さらにopencvを使用する為に端末から下記を入力しました。

sudo apt-get install python-opencv 
sudo apt-get install libopencv-dev

しかし、使用しているpython3.5.2には入って居らず。
python3.6.3にインストールされて居ます。

私はpython3.5.2でopencvを利用したいと思います。

どの様にすれば、python3.5.2でopencvが利用できますか?

私は下記を試しました。

$ python3.5 -m pip install python-opencv
Collecting python-opencv
  Could not find a version that satisfies the requirement python-opencv (from versions: )

No matching distribution found for python-opencv

$ sudo python3.5 -m pip install python-opencv

Could not find a version that satisfies the requirement python-opencv (from versions: )
No matching distribution found for python-opencv

$ sudo python3.5 -m pip3 install python-opencv
/usr/bin/python3.5: No module named pip3

$ sudo python3.5 -m pip install python-opencv

  Could not find a version that satisfies the requirement python-opencv (from versions: )
No matching distribution found for python-opencv

$ sudo python3.5.3 -m pip install python-opencv
sudo: python3.5.3: コマンドが見つかりません

$ python3.5.3 -m pip install python-opencv
python3.5.3: コマンドが見つかりません

$ python3.5.3 -m pip3 install python-opencv
python3.5.3: コマンドが見つかりません

 python3.5.3 -m pip3 install opencv
python3.5.3: コマンドが見つかりません

$ python3.5.3 -m pip install opencv
python3.5.3: コマンドが見つかりません

$ python3.5 -m pip install opencv
Collecting opencv
  Could not find a version that satisfies the requirement opencv (from versions: )
No matching distribution found for opencv

$ python3.5 -m pip3 install opencv
/usr/bin/python3.5: No module named pip3

$ python3.5 -m pip install opencv
Collecting opencv
  Could not find a version that satisfies the requirement opencv (from versions: )
No matching distribution found for opencv

$ python3.5 -m pip install python-opencv
Collecting python-opencv
  Could not find a version that satisfies the requirement python-opencv (from versions: )
No matching distribution found for python-opencv

$ python3.5 pip install python-opencv
python3.5: can't open file 'pip': [Errno 2] No such file or directory'

$ python3.5 pip3 install python-opencv
python3.5: can't open file 'pip3': [Errno 2] No such file or directory
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

過去の質問からみてpipは入っているようですので以下のコマンドで入るかと思います。(Python 3.5.3 :: Anaconda custom (x86_64)ではimport出来ます。)

pip install opencv-python

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/04/23 11:42

    上記を実行させて頂きました。
    Requirement already satisfied: opencv-python in /usr/local/lib/python3.6/dist-packages (3.4.0.12)
    Requirement already satisfied: numpy>=1.11.3 in /usr/local/lib/python3.6/dist-packages (from opencv-python) (1.14.2)

    python3.6.3で実行すると、確かに入って居ます。

    しかし、私が使用しているpythonはAnacondaでは無く、システムモデルです。
    Anacondaもinstallしておりますが、可能な限り、OS標準搭載されたpythonを利用したいと考えてます。

    拡張有る返答は可能でしょうか?

    キャンセル

0

python3.5 -m pip install ~とかでしょうか。

https://docs.python.jp/3/installing/index.html

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.75%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • Python 3.x

    5308questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。