質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.03%

Eclipseでpythonスクリプトの デバックをしようと思っています

受付中

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,365

jyama7777

score 12

Eclipse4.5(MARS)で pythonスクリプトの デバックしようと思っています。
パースペクティブを設定した後、インクプリタの設定のところで悩んでます。
画面左部のナビゲータのところでは the interpreter configured does not exist in the file system.というエラー表示
新規にインクプリタを選択し、名前およびインタープリターの実行可能ファイルを入力のところでは、
unable to get info on the interpreterというエラー表示が出ます。
この後はプロジェクトを作成し、スクリプトをインポートし、デバックの実行だと思うのですが。
お手数をかけますがよろしくお願いいたします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

回答 2

0

eclipseでpythonを実行したことがないので詳しくは分かりませんが、

・デバッグするのにPyDevというプラグインが必要
・Pleiadesにはデフォルトで梱包されている。が、そのままでは使えない
                   (2014.07時点、バージョンは不明)

・・・そうなので、試行錯誤がいろいろと必要なようです。
【参考】デバッガを使えるようにする

また、Marsは最近出たばかりのものなので、
まだプラグインが新しいEclipseに対応していない場合があります。
もしかしたら、こちらが原因かもしれませんね。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/07/06 15:55

    ご回答ありがとうございます
    Pleiades All in One   http://mergedoc.osdn.jp/
    からダウンロードしました。PyDev、Pleiades、eclipseがセットになっていて
    画面上部からグローバルブラウザーを選択することもできるようですが、
    どうやらご指摘の通り、何か設定が足りなくてデバック、インクプリタまで至らないようです。

    古いバージョンのeclipse も試してみますね。
    ありがとうございました。

    キャンセル

0

http://mergedoc.osdn.jp/からpythonのプラグインを入れただけで、
実際にそれだけではPythonを使えるようにはなりません。

eclipseを起動し、「ヘルプ」→「新規ソフトウェアのインストール」で
作業対象のところにhttp://pydev.org/updates
と入力してください。

するとpydevの候補が出てきます。
すべてチェックを選択し、完了を押してください。
するとpydevが使えるようになるはずです。

【追記】
そもそもなんですけど、デバッグしようとしてるってことは
上記のことはしたって認識で大丈夫ですか?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる