質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.33%

ruby on rails 5 gem fileのバージョンが異なるためサーバーが始動しません。

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 936

DaikiYano

score 6

 前提・実現したいこと

bundle install後にエラーが表示されサーバーが始動しなくなったのでこのエラーを解決させたいです。

 発生している問題・エラーメッセージ

ruby on railsで画像を追加するために
gemfileに
gem "carrierwave", "~> 0.10.0"
gem "mini_magick", "~> 4.3" 
の二行を追加しbundle installした後にエラーが発生しサーバーが起動しなくなりました。

エラーメッセージ
You've installed the binary version of mysql2.
  It was built using MySQL Connector/C version 6.1.6.
  It's recommended to use the exact same version to avoid potential issues.

  At the time of building this gem, the necessary DLL files were retrieved from:
  http://cdn.mysql.com/Downloads/Connector-C/mysql-connector-c-6.1.6-win32.zip

  This gem *includes* vendor/libmysql.dll with redistribution notice in vendor/README.


C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/activerecord-5.1.5/lib/active_record/connection_adapters/connection_specification.rb:188:in `rescue in spec': Specified 'mysql2' for database adapter, but the gem is not loaded. Add `gem 'mysql2'` to your Gemfile (and ensure its version is at the minimum required by ActiveRecord). (Gem::LoadError)

 該当のソースコード

ソースコード

 試したこと

gemの中のバージョンを古いものや新しいものに入れ替えたりしていますが、まだ解決できていません。
プログラミング初心者のため解決するのに苦労しています。
解決策が分かる方がいらっしゃいましたらコメントをいただけると幸いです。
宜しくお願いいたします。

 補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。
gem 'mysql2'
'rails', '~> 5.1.4'

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

MySQLを扱うために必要なファイルがないよって言われています

http://cdn.mysql.com/Downloads/Connector-C/mysql-connector-c-6.1.6-win32.zip
をダウンロードしてRubyのbin直下にコピーすればかいけつするとおもいます

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る