質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.21%

Windows10では、npm install, npm run dev で立ち上がるWebアプリがAmazonLinux上だと立ち上がらない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 902

Katsu-Ishii

score 13

メンバーが開発しているフロントのアプリをGitHubからローカルにCloneし、Windows上でnpm installをした後、npm run devで立ち上げると正常に立ち上がりますが、AmazonLinux上で同様の手順をとるとうまく立ち上がりません。
また、AmazonLinux上でnpm installをすると以下が出てきてしまいます。Linuxには対応していないということでしょうか。

npm WARN optional Skipping failed optional dependency /sane/fsevents:                                  
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.3              
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:                              
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.3              
npm WARN optional Skipping failed optional dependency /webpack-dev-server/chokidar/fsevents:           
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.3          

初心者で理解が追い付いていません。お力をいただければ幸いです。
よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

そのメッセージはワーニングなんで、インストールは済んでいる(はず)なので、そのまま走らせてみたらどーなります?

要するに、そのアプリが必要としているパッケージのバージョンが合わないってはなしだそーです
#そのエラーメッセージでぐぐるといろいろでてきますねー

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/07 17:00

    curlコマンドを叩いたところ、結果が返ってきました。
    npm の問題ではなく、ネットワークの問題の様です。大変失礼しました。

    未だにクライアント端末からは接続できませんが、別の観点で調査を続けます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる