質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.93%

Windows Rails開発環境エラー

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 692

ymatt

score 20

 前提・実現したいこと

Macで開発中のアプリですが、Git経由で、もう一台のPC(Windows 7 Professional, 64bit)も使って開発を続けたいと思っています。WindowsにRuby on Railsでの開発環境を構築するところでつまづいています。

RubyもRailsもインストールできているのですが、サーバーを立ち上げると以下のようなエラーが出てしまいます。調べたところ、Ruby2.4ではなく2.3にすると良いとあったので、Uruを使用し2.3に切り替えているのですが、エラーの内容を見ると依然としてRuby24-x64、つまり2.4でエラーになっているようです。

これはもともとのMacの環境が2.4だからでしょうか。ちなみにRails 5にアップグレードするという解決方法も見かけましたが、以前Rails 4で開発中にアップグレードして不具合が出たので、5へのアップグレードは試しておりません。

解決策ご存知の方いらっしゃいましたらご教示頂けますと幸甚です。

 発生している問題・エラーメッセージ

C:\Users\ytk\Desktop\app_clone\appappapp>rails s
=> Booting WEBrick
=> Rails 4.2.6 application starting in development on http://localhost:3000
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server
C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/activesupport-4.2.6/lib/active_support/co
re_ext/numeric/conversions.rb:121: warning: constant ::Fixnum is deprecated
C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/activesupport-4.2.6/lib/active_support/co
re_ext/numeric/conversions.rb:121: warning: constant ::Bignum is deprecated

C:\Users\ytk\Desktop\app_clone\appappapp>ruby -v
ruby 2.3.3p222 (2016-11-21 revision 56859) [x64-mingw32]
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

Ruby の Integer は,Fixnum と Bignum に分かれていた(すべての整数オブジェクトはどちらかのインスタンスだった)のが,Integer に一本化されたんですよね。
参考:Ruby 2.4でIntegerに一本化される整数 - Qiita

さて,メッセージを見ると activesupport のバージョンは 4.2.6 ですね。

4.2 系列の最新である 4.2.10 ではこの問題は直っているぽいので,4.2.10 を試してみては。

bundle update すれば rails や activesupport などのバージョンが 4.2.10 に上がると思います。

Mac で警告が出なかった理由は分かりませんが,gem のバージョンが Windows よりも高かったとかかもしれません。

Rails 4 系を 5 系に上げるのは,やはりいくらか注意が必要ですが,ものすごく難しいわけでもないので,開発が落ち着いたところでぜひチャレンジしてください。

Rails 5.0 で Turbolinks 関係がかなり変わりました。オートロード関係も変わりました。
よくハマるのが,belongs_to です。Rails 5 では,デフォルトで外部キーが必須となったので,無しでもよいことにするなら optional: true と書かなければなりません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/24 18:40

    もしかしたら、会社のパソコンなので権限不足なのかもしれません・・・Stack Overflowでも質問しましたが、権限の問題では?とのコメントがありました。
    https://stackoverflow.com/questions/48922072/error-rails-4-on-windows/48924642?noredirect=1#comment84893409_48924642

    キャンセル

  • 2018/02/24 18:44

    あー,そういうことはあるかもしれませんね。
    C:/Users/ytk/AppData/Local/Temp/ に Ruby からファイルを作ってみることはできますか?
    IO.write "C:/Users/ytk/AppData/Local/Temp/hoge.txt", "hogehoge"

    キャンセル

  • 2018/03/21 00:35

    大変遅くなり申し訳ありません。長期出張よりやっと帰って参りました。とりあえず、Aplication.html.erbから一時的に問題のjsexecのパートを削除することで対応しました・・・。いろいろとありがとうございました!

    キャンセル

0

まずはerrorとwarningは明確に区別してください

旧バージョンを使い続ける以上deprecated警告でるのはしょうがないです。

ruby 2.3に切り替えた上で
gem i rails --no-document -v 4.2.6
を実行しrailsをインストールし直してください

systemインストールされているRubyの設定を消さずに上書きしているせいで
切り替え先に存在せず、systemにあるgemの実行ファイルが呼び出された時
systemのrubyが実行されるのかもしれませんね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/24 18:34

    ご回答頂きありがとうございます。Warningですね。以降気をつけます。上記回答いただいた方にしたがってRailsを4.2.10にしたところWarningは消えました。ただ他のエラーが出ているので、もしそのエラーの解決に詰まったら立ち戻ってご教示頂いた方法を試してみたいと思います。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.93%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る