質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.12%

centos7にてmysqlがインストールができない

受付中

回答 3

投稿

  • 評価
  • クリップ 2
  • VIEW 6,289
退会済みユーザー

退会済みユーザー

 前提・実現したいこと

centos7にてmysqlをインストールしたいのですが、
下記のようなエラーが出ます。

 発生している問題・エラーメッセージ

Error: Package: mysql-community-server-5.7.21-1.el6.x86_64 (mysql57-community)
           Requires: libsasl2.so.2()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 該当のソースコード

# yum -y install mysql-community-server

 試したこと

rpm -Va --nofiles --nodigest

libsasl2.so.2というパッケージが必要なのでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

+2

既に解決済みでしたら失礼。

CentOS7.4 / MySQL5.7 で同様の事象に陥りました。
私は以下で解決できました。
※mysqlのyumのリポジトリが設定されている事が前提です

# cd /lib64
# ln -s libsasl2.so.3.0.0 libsasl2.so.2
# yum install mysql-community-server

一回エラーがでるとyumのcacheに残るっぽいので、上記で失敗する場合は yum clean all を実行してからだと良いかと思います。

ご参考までに。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

+1

Centos7にel6(centos6)のパッケージを入れようとしているから
yumがパッケージを探しに行けないためだと思われます。

mysql-community-server-5.7.21-1.el7.x86_64.rpm

をインストールしてみて下さい。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/23 00:52

    CentOS 7 用のリポジトリファイル(mysql57-community-release-el7-11.noarch.rpm)からインストールし直した方がいいと思います。

    キャンセル

0

libsasl2.so.2というパッケージが必要なのでしょうか?

そういうことになりそうですね。必要なパッケージの探し方のコツが下のURLで紹介されています。

https://www.geek.sc/archives/620

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/03/05 22:09

    横から失礼します。
    同様の事象で悩んでいます。
    上記URLから、yum whatprovidesを試してみましたが、No matches foundとなってしまいました。
    yum whatprovides libsasl2.so.2
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: ftp.iij.ad.jp
    * epel: ftp.iij.ad.jp
    * extras: ftp.iij.ad.jp
    * remi-php72: mirrors.mediatemple.net
    * remi-safe: mirrors.mediatemple.net
    * updates: ftp.iij.ad.jp
    No matches found


    もし解決方法が見つかっていれば教えていただきたいです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる