質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.12%

(SpringFramework)バージョンを確認したい

解決済

回答 2

投稿

  • 評価
  • クリップ 1
  • VIEW 14K+

_cocapeach

score 19

お世話になります。
【eclipse】springのバージョンを確認したい
上記の質問を見て、
「例えばSpringスタータープロジェクト(いわゆるSpringBoot)の1.3.6では、Springのバージョンは4.2.7-RELEASEです。」
という解答があったのですが、
springBootVersion = '1.5.10.RELEASE'の場合はSpringのバージョンは何になるのでしょうか?
また、それを確認する方法もご教示頂けますと幸いです。
よろしくお願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

 Maven での spring-boot に関係するバージョンの確認方法

  1. pom.xml を確認する (Effective POM : 右から二番目、日本語表記はしらん)
  2. https://github.com/spring-projects/spring-boot/blob/v[バージョン番号]/spring-boot-project/spring-boot-dependencies/pom.xml
    参考:2.0.0.RC1 ちなみに <parent> 以下にある <version> の設定値をそのまま設定
  3. buildパス上の jar ファイル spring-webmvc-[バージョン番号].jar を確認する

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/21 13:02

    有難うございます。コンパイラー準拠レベルを1.8→9に変更 JREをjava8→java9に変更して、スタータープロジェクト作成時にBootバージョンを2.0.0SNAPSHOTにするとspring-webmvc-5.0.4.jarになりました。
    java9でないとspring5は使えないということなんでしょうか。

    キャンセル

  • 2018/02/21 13:05

    JDK 8+ for Spring Framework 5.x
    https://projects.spring.io/spring-framework/

    キャンセル

  • 2018/02/21 14:02

    ターミナルでjavaのバージョンを確認すると9.0.4が入っていたので、1.8にダウングレードしてからプロジェクトを作成し直すと1.8でspring5を使用することができました。
    ご丁寧にご教示頂き、誠に有難うございました。

    キャンセル

0

Javaの道>掲示板(Spring frameworkのバージョンの見方)

↑こちらのやり方では確認できないでしょうか?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2018/02/21 11:32

    tkturbo様 お世話になります。
    上記サイトを拝見させて頂きましたが、Maven依存関係の中にSpring.jarというものは見つかりませんでした。

    キャンセル

  • 2018/02/21 11:32

    そういえば以前、管理者殿がプロキシ環境をはじくとか言ってた気が Javaroad (質問者の環境からみれるのかしら )

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.12%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る