質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.47%

  • PHP

    24528questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Apache

    2136questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

【Homebrew】Apache実行時にphp71用のモジュールの読み込みができない。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 942

yuki26s

score 2

HomebrewでApache,PHP,MySQLの環境構築を行っています。今回はApacheの設定ファイルhttpd.confの設定についての質問です。

ApacheとPHP7.1を連携させるには、以下のモジュールの読み込みが必要とわかり、httpd.confに以下の記載をしました。

LoadModule php7_module /usr/local/opt/php71/libexec/apache2/libphp7.so

しかし、sudo apachectl startを実行すると以下のエラーが出てしまいます。

httpd: Syntax error on line 178 of /usr/local/etc/httpd/httpd.conf: Cannot load /usr/local/opt/php71/libexec/apache2/libphp7.so into server: dlope

ネット調べてみると、php71のインストール時にオプション指定でbrew install php71 --with-httpdとすれば、自動的にモジュールが入ることがわかりましたが、自分はインストールをbrew install php71で実行していました。

この場合、phpをインストールし直した方が良いのでしょうか?それとも、モジュールのみインストールすることは可能でしょうか?

ご教授いただければ幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • asahina1979

    2018/01/29 12:51

    ん? Apache 2.2 向けの php7_module を 2.4 で設定したらそういうエラーになったきがするな

    キャンセル

回答 1

check解決した方法

0

最初はモジュールだけを何とか追加しようとしたのですが、調べても解決法が見つからなかったのでbrew uninstall php71でPHP自体を一度アンインストールした後、今度はbrew install php71 --with-httpdで再インストールしました。

しかしsudo apachectl startで再度同じエラーメッセージが出てしまい、念のためlocate libphp7.soでモジュールの場所を確認したところ上記パスは間違っていたことがわかり、修正の上実行したところ、正常に起動しました。

ちなみにパスは/usr/libexec/apache2/libphp7.soでした。

今回の一件は、パスの確認や使用環境に伴うオプション指定の必要性など、色々勉強になりました。

asahina1979さん、ご回答ありがとうございました!

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.47%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る

  • PHP

    24528questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Apache

    2136questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。