質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.25%

  • Ruby on Rails

    5348questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Apache

    1383questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。

Passenger(rails+apache2)を使ってHTTPでアクセスする

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 66

fara

score 3

前提・実現したいこと

railsアプリケーションをapache2の上で動かしたい

発生している問題・エラーメッセージ

Webページでのエラー
イメージ説明

エラーメッセージ(./apache2/error.log)
App 527 stderr: Cannot execute "/root/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/passenger-5.1.12/buildout/support-binaries/PassengerAgent": Permission denied (errno=13)
[ E 2017-12-19 01:21:33.9310 433/T9 age/Cor/Con/CheckoutSession.cpp:285 ]: [Client 2-1] Cannot checkout session because a spawning error occurred. The identifier of the error is 44faf08a. Please see earlier logs for details about the error.
App 536 stderr: Cannot execute "/root/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/passenger-5.1.12/buildout/support-binaries/PassengerAgent": Permission denied (errno=13)
[ E 2017-12-19 01:22:49.6659 433/To age/Cor/App/Implementation.cpp:304 ]: Could not spawn process for application /var/www/html/monolog/monolog_app: An error occurred while starting up the preloader.
  Error ID: 89c46846
  Error details saved to: /tmp/passenger-error-ApRFxC.html
  Message from application: Cannot execute "/root/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/passenger-5.1.12/buildout/support-binaries/PassengerAgent": Permission denied (errno=13)

試したこと

sudo chmod -R 775 /root/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/passenger-5.1.12/buildout/support-binaries/PassengerAgent

補足情報(言語/FW/ツール等のバージョンなど)

dockerの上で動かしています。Portは80:80, 443:443
初心者ですが、よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • CHERRY

    2017/12/19 12:45

    OS は、何でしょうか?

    キャンセル

回答 1

checkベストアンサー

0

ruby を rbenv で /root ディレクトリにインストールしているようですが、通常 /root ディレクトリは、 root ユーザーしかアクセスできません。

apache や passenger の設定がわかりませんが、通常は、apache や www といったユーザー権限で実行されます。

これらのユーザー(apache や www)では、/root/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0/gems/passenger-5.1.12/buildout/support-binaries/PassengerAgent や ruby 等にアクセスできませんので、Permission denied になっていると推測します。


「rbenv passenger」で、検索して出てきた以下のサイトの説明のように 複数のユーザで、 rbenv でインストールした ruby を利用したい場合は、/usr/local や /opt などのディレクトリにインストールして、設定する必要があります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/12/19 13:50

    ご丁寧にありがとうございます。rootユーザーでしかアクセスできないからエラーが出てしまっていたのですね。rbenv passengerについて調べてみます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.25%

関連した質問

同じタグがついた質問を見る

  • Ruby on Rails

    5348questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • Apache

    1383questions

    Apacheは、Apache HTTP Serverの略で、最も人気の高いWebサーバソフトウェアの一つです。安定性が高いオープンソースソフトウェアとして商用サイトから自宅サーバまで、多くのプラットフォーム向けに開発・配布されています。サーバーソフトウェアの不具合(NCSA httpd)を修正するパッチ(a patch)を集積、一つ独立したソフトウェアとして開発されました。