質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.23%

  • Ruby

    5475questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5370questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • RSpec

    151questions

    RSpecはRuby用のBDD(behaviour-driven development)フレームワークです。

Rspec Rails 3.にて再度インストールする方法に関してご相談したく・・・(><)

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 61

TOKUSABU

score 35

現在Rspecをインストールしています
こちらに関して現在下記のエラーが出ています

vagrant@vagrant-ubuntu-trusty:~/workspace/achieve$ bin/rspec
/home/vagrant/workspace/achieve/spec/blog_spec.rb:1:in `require': cannot load such file -- rails_helper (LoadError)
        from /home/vagrant/workspace/achieve/spec/blog_spec.rb:1:in `<top (required)>'
        from /home/vagrant/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/rspec-core-2.14.8/lib/rspec/core/configuration.rb:896:in `load'
        from /home/vagrant/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/rspec-core-2.14.8/lib/rspec/core/configuration.rb:896:in `block in load_spec_files'
        from /home/vagrant/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/rspec-core-2.14.8/lib/rspec/core/configuration.rb:896:in `each'
        from /home/vagrant/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/rspec-core-2.14.8/lib/rspec/core/configuration.rb:896:in `load_spec_files'
        from /home/vagrant/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/rspec-core-2.14.8/lib/rspec/core/command_line.rb:22:in `run'
        from /home/vagrant/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/rspec-core-2.14.8/lib/rspec/core/runner.rb:80:in `run'
        from /home/vagrant/.rbenv/versions/2.3.0/lib/ruby/gems/2.3.0/gems/rspec-core-2.14.8/lib/rspec/core/runner.rb:17:in `block in autorun'


調べていきましたところ、インストールをした時できたのが

    conflict  .rspec
Overwrite /home/vagrant/workspace/achieve/.rspec? (enter "h" for help) [Ynaqdh] y
       force  .rspec
       exist  spec
   identical  spec/spec_helper.rb


(オーバーライドしています)
で色々ぐぐりましたところどうやらrails_helper.rb が生成されていなく
生成する為には Rspec Rails 3.にて再度インストールする必要がある様子

https://stackoverflow.com/questions/25283417/rspec-rails-generator-doesnt-create-spec-rails-helper-rb

現在gemは下記を入れていますが、どの様にしてインストールすればよいかご教授を頂く事は可能でしょうか?何卒お知恵を拝借できれば幸いです・・・・・・・・(><)

gem 'rspec-rails', '~> 2.14.0'

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

修正方法として

gem 'rspec-rails', '~> 3.0'
とgemfileを書き換えて対応ができました

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.23%

関連した質問

同じタグがついた質問を見る

  • Ruby

    5475questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5370questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

  • RSpec

    151questions

    RSpecはRuby用のBDD(behaviour-driven development)フレームワークです。