質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.35%

  • PHP

    15157questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Ubuntu

    847questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。

Ubuntu17.10にPHP-FPMをインストールできません

受付中

回答 1

投稿 2017/12/03 15:53

  • 評価
  • クリップ 0
  • VIEW 70

Nikkoh_ban

score 2

Ubuntu17.10にPHP-FPMをインストールしようとしてもエラーが出てしまいインストールできません。
どなたか分かる方がいらっしゃいましたらお知恵を貸していただけないでしょうか?

発生している問題・エラーメッセージ

root@hoge:/etc/nginx# apt-get install php-fpm
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
php-fpm はすでに最新バージョン (1:7.1+55+ubuntu17.10.1+deb.sury.org+1) です。
アップグレード: 0 個、新規インストール: 0 個、削除: 0 個、保留: 7 個。
2 個のパッケージが完全にインストールまたは削除されていません。
この操作後に追加で 0 B のディスク容量が消費されます。
続行しますか? [Y/n] y
php7.1-fpm (7.1.12-1+ubuntu17.10.1+deb.sury.org+1) を設定しています ...
ucfr: Attempt from package php7.1-fpm  to take /etc/php/7.0/fpm/php.ini away from package php7.0-fpm
ucfr: Aborting.
dpkg: パッケージ php7.1-fpm の処理中にエラーが発生しました (--configure):
 サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 4 を返しました
dpkg: 依存関係の問題により php-fpm の設定ができません:
 php-fpm は以下に依存 (depends) します: php7.1-fpm ...しかし:
  パッケージ php7.1-fpm はまだ設定されていません。

dpkg: パッケージ php-fpm の処理中にエラーが発生しました (--configure):
 依存関係の問題 - 設定を見送ります
エラーメッセージは前の失敗から続くエラーであることを示しているので、レポートは書き込まれません。
                                                                                                処理中にエラーが発生しました:
 php7.1-fpm
 php-fpm
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@hoge:/etc/nginx# apt-get remove php-fpm
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
以下のパッケージは「削除」されます:
  php-fpm
アップグレード: 0 個、新規インストール: 0 個、削除: 1 個、保留: 7 個。
2 個のパッケージが完全にインストールまたは削除されていません。
この操作後に 12.3 kB のディスク容量が解放されます。
続行しますか? [Y/n] y
(データベースを読み込んでいます ... 現在 184843 個のファイルとディレクトリがインストールされています。)
php-fpm (1:7.1+55+ubuntu17.10.1+deb.sury.org+1) を削除しています ...
php7.1-fpm (7.1.12-1+ubuntu17.10.1+deb.sury.org+1) を設定しています ...
ucfr: Attempt from package php7.1-fpm  to take /etc/php/7.0/fpm/php.ini away from package php7.0-fpm
ucfr: Aborting.
dpkg: パッケージ php7.1-fpm の処理中にエラーが発生しました (--configure):
 サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 4 を返しました
処理中にエラーが発生しました:
 php7.1-fpm
E: Sub-process /usr/bin/dpkg returned an error code (1)

試したこと

removeも試みたのですが上記のようにエラーが出てしまいます。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

apt-get --reinstall install php-fpm

とかはどうなの?

投稿 2017/12/04 00:54

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2017/12/04 02:13

    回答いただきありがとうございます。
    試してみたところ
    ---
    dpkg: パッケージ php7.1-fpm の処理中にエラーが発生しました (--configure):
    サブプロセス インストール済みの post-installation スクリプト はエラー終了ステータス 4 を返しました
    dpkg: 依存関係の問題により php-fpm の設定ができません:
    php-fpm は以下に依存 (depends) します: php7.1-fpm ...しかし:
    パッケージ php7.1-fpm はまだ設定されていません。

    dpkg: パッケージ php-fpm の処理中にエラーが発生しました (--configure):
    依存関係の問題 - 設定を見送ります
    systemd (234-2ubuntu12.1) のトリガを処理しています ...
    エラーメッセージは前の失敗から続くエラーであることを示しているので、レポートは書き込まれません。
    man-db (2.7.6.1-2) のトリガを処理しています ...
    ureadahead (0.100.0-20) のトリガを処理しています ...
    処理中にエラーが発生しました:
    php7.1-fpm
    php-fpm
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ---
    とエラーになってしまいました。

    キャンセル

  • 2017/12/04 08:46

    バージョン付のものに変更してみて

    キャンセル

  • 2017/12/04 10:30 編集

    回答いただきありがとうございます。

    バージョン付きのものに変更して試してみたところインストール済みとなり処理されなかったため、ためしにアンインストールを試みたのですがエラーになってしまいました。
    ---
    hoge@hogehoge:~$ sudo apt-get --reinstall install php7.1-fpm
    [sudo] hoge のパスワード:
    パッケージリストを読み込んでいます... 完了
    依存関係ツリーを作成しています
    状態情報を読み取っています... 完了
    アップグレード: 0 個、新規インストール: 0 個、再インストール: 1 個、削除: 0 個、保留: 0 個。
    2 個のパッケージが完全にインストールまたは削除されていません。
    この操作後に追加で 0 B のディスク容量が消費されます。
    E: Internal Error, No file name for php7.1-fpm:amd64
    hoge@hogehoge:~$ sudo apt-get purge php7.1-fpm
    パッケージリストを読み込んでいます... 完了
    依存関係ツリーを作成しています
    状態情報を読み取っています... 完了
    以下のパッケージは「削除」されます:
    php-fpm* php7.1-fpm*
    アップグレード: 0 個、新規インストール: 0 個、削除: 2 個、保留: 0 個。
    2 個のパッケージが完全にインストールまたは削除されていません。
    この操作後に 4,646 kB のディスク容量が解放されます。
    続行しますか? [Y/n] y
    (データベースを読み込んでいます ... 現在 184843 個のファイルとディレクトリがインストールされています。)
    php-fpm (1:7.1+55+ubuntu17.10.1+deb.sury.org+1) を削除しています ...
    php7.1-fpm (7.1.12-1+ubuntu17.10.1+deb.sury.org+1) を削除しています ...
    man-db (2.7.6.1-2) のトリガを処理しています ...
    (データベースを読み込んでいます ... 現在 184826 個のファイルとディレクトリがインストールされています。)
    php7.1-fpm (7.1.12-1+ubuntu17.10.1+deb.sury.org+1) の設定ファイルを削除しています ...
    ucfr: Association belongs to php7.0-fpm, not php7.1-fpm
    ucfr: Aborting
    dpkg: パッケージ php7.1-fpm の処理中にエラーが発生しました (--purge):
    サブプロセス インストール済みの post-removal スクリプト はエラー終了ステータス 5 を返しました
    処理中にエラーが発生しました:
    php7.1-fpm
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    hoge@hogehoge:~$

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.35%

関連した質問

同じタグがついた質問を見る

  • PHP

    15157questions

    PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

  • Ubuntu

    847questions

    Ubuntuは、Debian GNU/Linuxを基盤としたフリーのオペレーティングシステムです。