質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.35%

  • Python 3.x

    2442questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。

python pip インストール時のエラーについて

受付中

回答 0

投稿 2017/11/29 09:49

  • 評価
  • クリップ 0
  • VIEW 85

bof

score 8

pqkmeansというパッケージのあるディレクトリにおいて、pip install pqkmeansをコマンドプロンプトで行ったところ、以下のようなエラーが出ました。

このエラーに対して、この http://msdn.microsoft.com/en-us/windows/bb980924.aspx URLに従い、SDKをダウンロードし、visual studio 2010を64bitに対応させる。という対処で正しいのか伺いたいです。

また64bitにする手順などをお教えいただきたく質問させていただきました。

よろしくお願いいたします。

コマンドプロンプト内のエラー表記(一部抜粋)

Collecting pqkmeans
  Using cached pqkmeans-1.0.1.tar.gz
Requirement already satisfied: numpy in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from pqkmeans)
Requirement already satisfied: scikit-learn in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from pqkmeans)
Requirement already satisfied: pipe in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from pqkmeans)
Requirement already satisfied: scipy in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from pqkmeans)
Requirement already satisfied: typing in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from pqkmeans)
Requirement already satisfied: six in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from pqkmeans)
Requirement already satisfied: texmex_python==1.0.0 in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from pqkmeans)
Requirement already satisfied: lshash3 in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from texmex_python==1.0.0->pqkmeans)
Requirement already satisfied: bitarray in c:\users\hidek\anaconda3\envs\py36con\lib\site-packages (from lshash3->texmex_python==1.0.0->pqkmeans)
Building wheels for collected packages: pqkmeans
  Running setup.py bdist_wheel for pqkmeans ... error
・
・
・
 -- Building for: Visual Studio 10 2010
  CMake Error at CMakeLists.txt:2 (project):
    Cannot enable 64-bit tools with Visual Studio 2010 Express.

    Install the Microsoft Windows SDK v7.1 to get 64-bit tools:

      http://msdn.microsoft.com/en-us/windows/bb980924.aspx


  -- Configuring incomplete, errors occurred!
  See also "C:/Users/hidek/AppData/Local/Temp/pip-build-ilfzefno/pqkmeans/build/temp.win-amd64-3.6/Release/CMakeFiles/CMakeOutput.log".

Failed building wheel for pqkmeans

    File "C:\Users\hidek\Anaconda3\envs\py36con\lib\subprocess.py", line 291, in check_call
      raise CalledProcessError(retcode, cmd)
  subprocess.CalledProcessError: Command '['cmake', 'C:\\Users\\hidek\\AppData\\Local\\Temp\\pip-build-ilfzefno\\pqkmeans', '-DCMAKE_LIBRARY_OUTPUT_DIRECTORY=C:\\Users\\hidek\\AppData\\Local\\Temp\\pip-build-ilfzefno\\pqkmeans\\build\\lib.win-amd64-3.6', '-DPYTHON_EXECUTABLE=C:\\Users\\hidek\\Anaconda3\\envs\\py36con\\python.exe', '-DCMAKE_LIBRARY_OUTPUT_DIRECTORY_RELEASE=C:\\Users\\hidek\\AppData\\Local\\Temp\\pip-build-ilfzefno\\pqkmeans\\build\\lib.win-amd64-3.6', '-A', 'x64']' returned non-zero exit status 1.

  ----------------------------------------
  Failed building wheel for pqkmeans
  Running setup.py clean for pqkmeans
Failed to build pqkmeans
Installing collected packages: pqkmeans
  Running setup.py install for pqkmeans ... error
    Complete output from command C:\Users\hidek\Anaconda3\envs\py36con\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\hidek\\AppData\\Local\\Temp\\pip-build-ilfzefno\\pqkmeans\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\hidek\AppData\Local\Temp\pip-00whz064-record\install-record.txt --single-version-externally-managed --compile:
・
・
・
Command "C:\Users\hidek\Anaconda3\envs\py36con\python.exe -u -c "import setuptools, tokenize;__file__='C:\\Users\\hidek\\AppData\\Local\\Temp\\pip-build-ilfzefno\\pqkmeans\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record C:\Users\hidek\AppData\Local\Temp\pip-00whz064-record\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in C:\Users\hidek\AppData\Local\Temp\pip-build-ilfzefno\pqkmeans\
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.35%

関連した質問

同じタグがついた質問を見る

  • Python 3.x

    2442questions

    Python 3はPythonプログラミング言語の最新バージョンであり、2008年12月3日にリリースされました。