質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

91.39%

  • Ruby

    5162questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5031questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

Ruby on Rails5へアップデートができない

受付中

回答 1

投稿 2017/11/28 21:46

  • 評価
  • クリップ 0
  • VIEW 45

ethno

score 2

経緯

Ruby on Rails 4.2.1から5へバージョンを上げるため、

$ bundle update
$ bundle update rails


を試みたところ、エラーが発生。
gemfileに問題のgemの最新バージョンを書き込むが、
これ以上対策が思いつかず、、
どなたか解決方法をご教示いただきたいです。

>>環境
Ruby 2.4.1
Ruby on Rails 4.2.1

エラー内容

Bundler could not find compatible versions for gem "activemodel":
  In Gemfile:
    carrierwave (= 1.2.1) was resolved to 1.2.1, which depends on
      activemodel (>= 4.0.0)

    rails (= 5.0.1) was resolved to 5.0.1, which depends on
      activemodel (= 5.0.1)

Bundler could not find compatible versions for gem "json":
  In Gemfile:
    json (= 2.1.0)

    sdoc (= 0.4.2) was resolved to 0.4.2, which depends on
      json (>= 1.7.7, ~> 1.7)

Bundler could not find compatible versions for gem "railties":
  In Gemfile:
    devise (= 4.3.0) was resolved to 4.3.0, which depends on
      railties (< 5.2, >= 4.1.0)

    jquery-rails (= 4.3.1) was resolved to 4.3.1, which depends on
      railties (>= 4.2.0)

    rails (= 5.0.1) was resolved to 5.0.1, which depends on
      railties (= 5.0.1)

    sass-rails (= 5.0.7) was resolved to 5.0.7, which depends on
      railties (< 6, >= 4.0.0)


>>gemfile内の記述

source 'https://rubygems.org'

gem 'rails',        '5.0.1'
gem 'sass-rails',   '5.0.7'
gem 'uglifier',     '3.2.0'
gem 'coffee-rails', '4.2.2'
gem 'jquery-rails', '4.3.1'
gem 'turbolinks',   '5.0.1'
gem 'jbuilder',     '2.7.0'
gem 'sdoc',         '0.4.2', group: :doc
gem 'omniauth'
gem 'omniauth-twitter','1.4.0'
gem 'settingslogic'
gem 'sprockets-rails', '3.2.1'
gem 'activemodel',  '5.0.1'
gem 'activerecord', '5.0.1'
gem 'activesupport', '5.0.1'
gem 'actionpack' ,  '5.0.1'
gem 'actionview' ,  '5.0.1'
gem 'railties' ,    '5.0.1'
gem 'devise',       '4.3.0'
gem 'seed-fu', '2.3.6'
gem 'json', "2.1.0"
gem 'rails-dom-testing', "2.0.3"

gem 'bootstrap-sass'
gem 'kaminari'
gem 'google-analytics-rails'


gem 'ckeditor'
gem 'carrierwave' , '1.2.1'
gem 'mini_magick'

gem "redcarpet", "~> 2.3.0"

group :development, :test do
  gem 'sqlite3',     '1.3.9'
  gem 'byebug',      '3.4.0'
  gem 'web-console', '3.5.1'
  gem 'spring',      '1.1.3'
end

group :production do
  gem 'pg',             '0.17.1'
  gem 'rails_12factor', '0.0.2'
end

また、gem listを見た際に、重複しているバージョンがあったのですが、
gem cleanupしても修復せず、、

$ gem list

*** LOCAL GEMS ***

actioncable (5.1.4)
actionmailer (5.1.4)
actionpack (5.1.4, 5.0.0)
actionview (5.1.4, 5.0.0)
activejob (5.1.4)
activemodel (5.1.4, 5.0.0)
activerecord (5.1.4)
activesupport (5.1.4, 5.0.0)
...
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+2

Gemfile にバージョンをガチガチに固定して書いてしまっているので,互換性のある組み合わせになっていない,ということかなと思います。

エラーメッセージにも書いてありますが,sdoc 0.4.2 は json (>= 1.7.7, ~> 1.7) に依存しています。
>= 1.7.7 は 1.7.7 以上ということですが,~> 1.7 は 1.7 以上 2.0 未満ということです。
ところが json のバージョンを 2.1.0 に固定してしまっているので両立しないわけです。

Gemfile から余計な記述を無くしていく必要があります。

json は,sdoc が依存しているという以上の使われ方をしないのであれば,Gemfile に書く必要がありません。(ほかでも使っていて,そちらでバージョンに制約があるなら書く必要がありますが)

それから rails は activemodel, activerecord, activesupport, actionpack, actionview, railties  などに依存していますので,Gemfile には rails だけ書いておけば,これらは書く必要がありません。

このとき,rails のバージョンも

gem 'rails',        '5.0.1'

みたいに完全に固定しないで,

gem 'rails',        '~> 5.0.1'

とするといいと思います。これは 5.0.1 以上 5.2.0 未満ということで,バグフィクスなどで 5.0.2 とかが出た場合に Gemfile を修正せずにすみます。
ちなみに 5.0 系の最新版は 5.0.6 です。
rails の最新版は 5.1.4 です。

ためしに

rails new hogehoge

して空の rails プロジェクトを作って,Gemfile を比較してみてはいかがでしょう。
何が余計な記述か,バージョンはどう書くのが良いかがわかると思います。

このとき,インストールされている最新の rails のバージョンでやる場合は上記でいいですが,もし何か事情があって,古い rails でやりたいときは,

rails _5.0.1_ new hogehoge

のようにバージョンを指定することができます。(当該バージョンの rails は事前にインストールしておきます)

投稿 2017/11/28 23:41

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

ただいまの回答率

91.39%

関連した質問

同じタグがついた質問を見る

  • Ruby

    5162questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Ruby on Rails

    5031questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。