質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.10%

compass --version でのエラー

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,972

score 8

compassを一度installしたのですが、エラーがあったため、uninstallして、もう一度installしました。そうするとcompass --versionのcommandでいかのようなerrorがでてきており、原因がわからないため困っております。。

以下のようなメッセージがでます。

Application/Gemfile:2: warning: duplicated key at line 2 ignored: :git Application/Gemfile:2: warning: duplicated key at line 2 ignored: :git .rvm/gems/ruby-2.2.2/gems/bundler-1.9.9/lib/bundler/dsl.rb:35:in rescue in eval_gemfile': Gemfile syntax error on line 2: unterminated string meets end of file (Bundler::GemfileError) from /Users/???/.rvm/gems/ruby-2.2.2/gems/bundler-1.9.9/lib/bundler/dsl.rb:31:ineval_gemfile' from /Users/???/.rvm/gems/ruby-2.2.2/gems/bundler-1.9.9/lib/bundler/dsl.rb:10:in evaluate' from /Users/???/.rvm/gems/ruby-2.2.2/gems/bundler-1.9.9/lib/bundler/definition.rb:25:inbuild' from /Users/???/.rvm/gems/ruby-2.2.2/gems/bundler-1.9.9/lib/bundler.rb:155:in definition' from /Users/???/.rvm/gems/ruby-2.2.2/gems/bundler-1.9.9/lib/bundler.rb:118:insetup' from /Users/???/.rvm/gems/ruby-2.2.2/gems/bundler-1.9.9/lib/bundler.rb:134:in require' from /Users/???/.rvm/gems/ruby-2.2.2/gems/compass-1.0.3/bin/compass:26:in' from /Users/???/.rvm/gems/ruby-2.2.2/bin/compass:23:in load' from /Users/???/.rvm/gems/ruby-2.2.2/bin/compass:23:in

' from /Users/???/.rvm/gems/ruby-2.2.2/bin/ruby_executable_hooks:15:in eval' from /Users/???/.rvm/gems/ruby-2.2.2/bin/ruby_executable_hooks:15:in
'

どなたか対象法をご存知でないでしょうか。。

教えていただけますと助かります。

よろしくお願いします。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • gouf

    2015/05/22 23:56

    パッと見で2つのエラーに遭遇しているようですね。もしかするとGemfile (の2行目前後)に関するエラーなので、当該Gemfile の内容を追記していただけないでしょうか

    キャンセル

  • tateil

    2015/05/23 08:04

    ありがとうございます!

    Gemfileの記述は以下のようになっております。

    group :assets
    gem 'compass', :git => 'git://github.com/chriseppstein/compass.git', :git => 'git://github.com/Compass/compass-rails.git

    よろしくお願いします。

    キャンセル

回答 1

0

group :assets gem 'compass', :git => 'git://github.com/chriseppstein/compass.git', :git => 'git://github.com/Compass/compass-rails.git

の内容を、bundle init した真っ更なGemfile に書き込んでbundle してみたところ、同様のエラーが得られました

duplicated key は本来ひとつだけ渡されるはずのキー値に2 つ以上値の割り当てをしようとした時に起きるエラーのようですね

gem 'compass-rails' の記述漏れのようです


assets グループとして2つ以上のgem を登録したい場合は、以下のように記述します

group :assets do
  gem 'compass', github: 'chriseppstein/compass'
  gem 'compass-rails', github: 'Compass/compass-rails'
end

1行1行記述する場合は以下のように

gem 'compass', github: 'chriseppstein/compass', group: [:assets]
gem 'compass-rails', github: 'Compass/compass-rails', group: [:assets, :development] # 複数割り当てできる

GitHub を対象としてgem をインストールする場合は、:github での指定が有効です

以上、何か参考になれば幸いです


## Links

Bundler: The best way to manage a Ruby application's gems
git - Bundler: The best way to manage a Ruby application's gems
groups - Bundler: The best way to manage a Ruby application's gems
Ruby - ツールを使いたいだけの人のための bundler 入門 (例: vagrant + veewee) - Qiita

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2015/05/25 00:17

    確認してみましたが、chriseppstein/compass というリポジトリは存在していないようです
    どうやら、Compass Org に移管されたみたいです

    なので、chriseppstein/compass → Compass/compass と書き換える必要がありそうです

    キャンセル

  • 2015/05/26 02:57

    ありがとうございます。

    おっしゃる通りにレポジトリも変更してみたのですが、未だにエラーが出たため、stackoverflowを参考に、sassとcompassをuninstallsいてみましたが、まだエラーが出ます。。

    /Users/???????/.rvm/rubies/ruby-2.0.0-p645/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:315:in `to_specs': Could not find 'compass' (>= 0) among 8 total gem(s) (Gem::LoadError)
    Checked in 'GEM_PATH=/Users/???????/Dropbox/bitcoinApplication/vendor/bundle/ruby/2.0.0', execute `gem env` for more information
    from /Users/???????/.rvm/rubies/ruby-2.0.0-p645/lib/ruby/site_ruby/2.0.0/rubygems/dependency.rb:324:in `to_spec'
    from /Users/???????/.rvm/rubies/ruby-2.0.0-p645/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:64:in `gem'
    from /Users/???????/.rvm/gems/ruby-2.0.0-p645@railstutorial_rails_4_0/bin/compass:22:in `<main>'
    from /Users/???????/.rvm/gems/ruby-2.0.0-p645@railstutorial_rails_4_0/bin/ruby_executable_hooks:15:in `eval'
    from /Users/???????/.rvm/gems/ruby-2.0.0-p645@railstutorial_rails_4_0/bin/ruby_executable_hooks:15:in `<main>'

    Gemfileは以下のような状態です。
    gem 'compass', github: 'Compass/compass', group: [:assets]
    gem 'compass-rails', github: 'Compass/compass-rails', group: [:assets, :development] # 複数割り当てできる

    他のオンラインフォーラムも参考にしたのですが、うまくいきません。。

    ご教授いただけますと幸いです。

    キャンセル

  • 2015/05/26 09:22

    単純に、

    ```
    gem 'compass'
    gem 'compass-rails'
    ```

    でのインストールはできますでしょうか

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る