質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.49%

【EIGRP】Pingがある一定の距離で届かなくなる挙動を改善したい

解決済

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 1,514

score 7

前提

ルーティングプロトコル「EIGRP」の勉強をしており、Catalyst3560を用い、
下記の環境下での検証を行っております。その際、動作が上手くいかなかった為、今回質問させていただきました。

どの様に改善するとホスト同士の通信が可能となるのでしょうか。
手あたり次第対応いたしましたが、通信できず詰まってしまった為、ご教示いただければ幸いです。
sh ver / sh run を記載したため大変見辛くなっており恐れ入りますが、何卒宜しくお願い致します。

実現したいこと

イメージ説明
このような環境下でEIGRPを用いて、ホスト同士の通信を成功させる。
(Ripv1・Ripv2では成功しております)

発生している問題・エラーメッセージ

  • 上図の矢印のようにPingを飛ばした時、点線以降のインターフェースへの着弾失敗(Destination host unreachable.)

  • また[PC2]と[SW3]の間に、[SW4][SW5]…とデバイスを追加した場合、同様な距離で「Destination host unreachable.」
    (簡略図。左側からPingを飛ばす。〇:着弾成功、×:着弾失敗)
    [SW2]out〇→in〇[SW3]out〇→in〇[SW4]out×→in×[SW5]
    [SW3]out〇→in〇[SW4]out〇→in〇[SW5]out×→in×[PC2]

該当のソースコード

  • show running(SW1)
SW1#sh run
Building configuration...

Current configuration : 1091 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
 no switchport
 ip address 192.168.0.1 255.255.255.0
 no ip split-horizon eigrp 1
(中略)
interface FastEthernet0/8
 no switchport
 ip address 192.168.1.1 255.255.255.0
 no ip split-horizon eigrp 1
!
interface GigabitEthernet0/1
!
interface Vlan1
 no ip address
 shutdown
!
!
router eigrp 1
 no auto-summary
 eigrp stub connected summary
 network 192.168.0.1 0.0.0.0
 network 192.168.1.1 0.0.0.0
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end
  • show running(SW2)
SW2#sh run
Building configuration...

Current configuration : 1081 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
ip routing
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
 no switchport
 ip address 192.168.1.2 255.255.255.0
 no ip split-horizon eigrp 1
(中略)
interface FastEthernet0/8
 no switchport
 ip address 192.168.2.1 255.255.255.0
 no ip split-horizon eigrp 1
!
interface GigabitEthernet0/1
!
interface Vlan1
 no ip address
!
!
router eigrp 1
 no auto-summary
 eigrp stub connected summary
 network 192.168.1.2 0.0.0.0
 network 192.168.2.1 0.0.0.0
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end
  • show running(SW3)
SW3#sh run
Building configuration...

Current configuration : 1126 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
vtp mode transparent
ip subnet-zero
ip routing
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 50,60
!
!
!
interface FastEthernet0/1
 no switchport
 ip address 192.168.2.2 255.255.255.0
 no ip split-horizon eigrp 1
(中略)
interface FastEthernet0/8
 no switchport
 ip address 192.168.3.1 255.255.255.0
 no ip split-horizon eigrp 1
!
interface GigabitEthernet0/1
!
interface Vlan1
 no ip address
 shutdown
!
!
router eigrp 1
 no auto-summary
 eigrp stub connected summary
 network 192.168.2.2 0.0.0.0
 network 192.168.3.1 0.0.0.0
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end

  • show ip eigrp 1 neighbor(SW1)
EIGRP-IPv4:(1) neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.2             Fa0/8             14 17:48:25    2   200  0  40
  • show ip eigrp 1 neighbor(SW2)
EIGRP-IPv4:(1) neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.2.2             Fa0/8             14 17:48:26    1   300  0  11
1   192.168.1.1             Fa0/1             14 17:49:47    3   300  0  19
  • show ip eigrp 1 neighbor(SW3)
EIGRP-IPv4:(1) neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.2.1             Fa0/1             12 17:48:58    1   200  0  39

  • show ip eigrp 1 topology(SW1)
P 192.168.2.0/24, 1 successors, FD is 30720
        via 192.168.1.2 (30720/28160), FastEthernet0/8
P 192.168.0.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/1
P 192.168.1.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/8
  • show ip eigrp 1 topology(SW2)
SW2>sh ip e 1 to
P 192.168.3.0/24, 1 successors, FD is 30720
        via 192.168.2.2 (30720/28160), FastEthernet0/8
P 192.168.2.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/8
P 192.168.0.0/24, 1 successors, FD is 30720
        via 192.168.1.1 (30720/28160), FastEthernet0/1
P 192.168.1.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/1
  • show ip eigrp 1 topology(SW3)
P 192.168.3.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/8
P 192.168.2.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet0/1
P 192.168.1.0/24, 1 successors, FD is 30720
        via 192.168.2.1 (30720/28160), FastEthernet0/1

  • show version(SW1)
Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(50)SE, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 27-Feb-09 22:41 by weiliu
Image text-base: 0x00003000, data-base: 0x01700000

ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(35r)SE2, RELEASE SOFTWARE (fc1)

(中略)

Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 9     WS-C3560-8PC       12.2(50)SE            C3560-IPBASE-M


Configuration register is 0xF
  • show version(SW2)
Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(50)SE, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 27-Feb-09 22:41 by weiliu
Image text-base: 0x00003000, data-base: 0x01700000

ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(35r)SE2, RELEASE SOFTWARE (fc1)

SW2 uptime is 18 hours, 38 minutes
System returned to ROM by power-on
System image file is "flash:c3560-ipbase-mz.122-50.SE/c3560-ipbase-mz.122-50.SE.bin"

(中略)

Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 9     WS-C3560-8PC       12.2(50)SE            C3560-IPBASE-M


Configuration register is 0xF
  • show version(SW3)
Cisco IOS Software, C3560 Software (C3560-IPBASE-M), Version 12.2(50)SE, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 27-Feb-09 22:41 by weiliu
Image text-base: 0x00003000, data-base: 0x01700000

ROM: Bootstrap program is C3560 boot loader
BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(35r)SE2, RELEASE SOFTWARE (fc1)

SW3 uptime is 18 hours, 41 minutes
System returned to ROM by power-on
System image file is "flash:c3560-ipbase-mz.122-50.SE/c3560-ipbase-mz.122-50.SE.bin"

(中略)

Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 9     WS-C3560-8PC       12.2(50)SE            C3560-IPBASE-M


Configuration register is 0xF

試したこと

  • スプリットホライズン無効化
  • それぞれの FastEthernet に関して
    L2にした場合(swichportにし、VlanからIPアドレスを割り振る)
    L3にした場合(no swichportにし、インターフェースへ直接IPアドレスを割り振る)
    それぞれ検証済み

補足情報(言語/FW/ツール等のバージョンなど)

  • 使用ツール
    tera term
  • OS
    Microsoft Windows 10 Pro

備考

  • IOSのライセンスがIP Baseなので、EIGRPの機能制限によりこの様な挙動をしてしまうのでしょうか。。
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

SW2の「eigrp stub connected summary」が原因でしょうねぇ。
これを消してください。

SW2はハブ側としてSW1とSW3のルートをそれぞれに配信する役割ですが、
「eigrp stub connected summary」により、自身がスタブ側としてconnectedとサマリルートしか配信しない設定になっていることが原因と思われます。
※192.168.0.0/24と192.168.3.0/24はconnectedでもなければサマリルートでもない

そもそもeigrpの動作を学習したいならstub設定は一旦全て外したほうが良いかと。ややこしくなるので。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.49%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る